Recharter Term Error

When I click on Recharter, then choose the 12 month term option, I get an error saying “Charter id for Internet Recharter batch should have future effective date.”. I do know we are late starting the process, but I can’t get past this point right now.

You shouldn’t have to choose the term. It should already be filled in. Is that not the case? What is the expire date shown? A couple screenshots could be helpful.

This is truly all that I see after clicking “Recharter”. Thanks for the followup!

That definitely not the norm. What happens after you click save?

ETA I’m being told asking for the term was added this year. It didn’t show up for me in the test system…

This is the next screen that I get. The 4 status balls continue circling forever with no end (10+ minutes on three occasions).

My first suggestion would be to try an incognito or private window.

Thank you. I just tried the incognito mode to no avail, unfortunately.

Try holding down SHIFT + Refresh page at same time

Thanks for the suggestion, unfortunately that looped me back to our Internet Advancement Roster but I’m still stuck with the same error.
Thanks to all for the help!

I’m a K3D for my Pack. When I click on the recharter link, I get the same “term” selection form, which I thought was odd. I’m not handling recharter this year, so I wasn’t too concerned, but if there’s a larger issue it would be good to know.

It’s something new that they added this year.

1 Like

I read somewhere it was added to help councils start to standardize on expire dates. One isn’t supposed to change it unless directed to.

1 Like

I’m in the same Pack as the original poster. Does anyone happen to know who might be the best person to contact?

It will vary by council, but likely there is a commissioner (maybe your unit commissioner) who is coordinating recharter. They would be the best to start with. This person may be your district executive.

A way to tell who to contact is they have likely already sent 1, 2, or 3 emails making sure you finish on time!

Does this seem to be resolved? might need to SHIFT + Refresh