Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Report could not be loaded. Please try again

And I did double-check our troop roster in my.scouting to make sure they were each only listed once.

Ethan H. is the one with userID 2721828. I have ended his youth membership in the troop.

Wait a few minutes and see if the report works for you now. You might need to log out, then log back in.

Unfortunately, I’m getting the same error still. I logged out, cleared all cookies and site data, logged back in. Double checked the userID as well in case there was another scout with this problem (we had more than one scouts that aged out and stayed with the troop as adults) but I’m still getting the message about userID 2721828

We don’t use scoutbook in our troop, so I never look at it. But looking at it now, I do see M. O. listed twice in scoutbook. He only appears once in the troop roster in internet advancement though. Could that be causing a problem?

Sean,

I edited you post to remove the youth’s name as I have found the problem with his record and no longer need it. I’m investigating the cause of MO being listed multiple times.

Sean,

For MO, go to My Dashboard → Administration → Troop 380 → Troop Roster → MO → M’s Positions. You will see he has 2 open memberships in the troop. Click on the one that does not list the patrol, add an end date then click Update. This will remove the duplicate entry on your roster.

Unfortunately, the tool I have to end his extra troop membership does not provide an indication of which one to end. This needs to be done in Scoutbook by someone with the correct permissions, which you have.

Both MO are assigned to the same patrol. They are identical in every way I can see. They even have the same userId when I check the scout’s profile.

I can end one, but it’s making a choice at complete random. As they appear to be completely identical to me, is there a “right” and “wrong” one to end or does it not matter?

I also do not see anything that has the word “positions” in when I select either M.O. entry from the troop roster.

There is a “memberships” option in which for both M.O. I see both patrol and non-patrol membership with our troop. If I choose to “reassign patrol” for the non-patrol membership and then cancel the reassignment, I’m left on a screen that looks like it will let me end the membership.

Is this what I should be doing?

You should be looking at the Scout’s Memberships.

It sounds like the Scout has a troop membership and a patrol membership. Please click on the troop membership and add an end date. Also, please keep the box checked next to “position approved”.

Okay, did that. I now only have one M.O. on the troop roster. Yay! Thanks for helping with that.

However I’m still getting the same error with the same user ID when attempting to generate the advancement report.

Is the problem maybe cause by the fact that E.H. who is now an ASM does have awards on the advancement report I’m trying to generate. He earned them last year but at this point in time when trying to generate the report he is not on the troop roster as a scout?

@SeanYeomans That might be it.

Is it a Purchase Order that you’re trying to generate? If so, do you have the PO number?

I don’t have a purchase order because I can’t get to that point. All I can get to is the advancement report preview. And even that preview is a whole different pile of problems. The report that I’m trying to generate is missing a bunch of awards. But we were able to use a report out of Troopmaster for our February CoH to at least purchase the awards we needed by working with the office. So I just really need to get this one generated a cleared out so our May CoH isn’t another massive pile of difficulty to get the awards.

@SeanYeomans Ethan H. also had a Venturing membership that was still open, when it shouldn’t be (he did not recharter with the crew). I have closed it.

Can you try again and see if you still get the error message?