Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.

Scouting Forums

Report could not be loaded. Please try again

Attempting to generate the advancements report (to try to investigate why it is missing a lot of advancements!) I am getting “Report could not be loaded. Please try again” after hitting “Generate Report.”

After returning to the Internet Advancement tab I get a pop-up message “Unable to find the user for the given id 2721828”


I have passed this on to the developers.

1 Like


The developers would like the URL of for the report generating the error.

I am also getting this same message.

Please post the URL that is generating this message.

Is this what you are looking for?



What we need is the URL from the page that has the error.


This is the URL. This is what happens… I recorded some advancements and I see the little notification up top that says needs purchasing. When I go in to that I click generate report. When I do this I get to the page for the URL I just posted. THis is a blank page that says the report could not be generated please try again.

When close that window and go back to the report preview where it says what needs to be purchased that error message pops up and then goes away.

I willl go back into it and try to get screen grabs for it.

screen grab 1.pdf (25.3 KB) screen grab 2.pdf (103.1 KB)

That is exactly what I’m experiencing whether I do it from the “purchase” at the top of the screen or the “run report” at the top of the roster.

Any further updates on this? It’s still not working.

Not yet. The developers are looking into an API issue that could be causing this and other problems.

1 Like

It’s still not working. Do we have any estimate on when this will be fixed?

I have passed this to the developers. Thanks for the update.

This is STILL happening, is there any indication of when it will be fixed?

Anything? Anything at all?

What happens if you log out, clear your cache, log back in, and run the report immediately?

I get the same result. In both Edge and Chrome. I even downloaded firefox to be absolutely certain there was no cache involved and got the same result.

@SeanYeomans I think I found one issue: You have a Scout now Assistant Scoutmaster with the initials E.H. who has a Scout membership and an Assistant Scoutmaster position. He cannot have both at the same time, so I think this is probably causing issues with the code.

That’s an excellent idea but I don’t know if that’s it. We have an Ethan H. who is an assistant scoutmaster and an Eric H. who is a scout. So they are not the same person despite having the same initials. Ethan was a scout in 2020 but is now an ASM in 2021.