Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Same issue - Needs Approval Report doesn’t list what needs approval

I am having the same issue as was closed on Dec '20 by Michael Crotty. The thread was closed yet, still having these issues.

“When I go to the Needs Approval Report in Scoutbook, sometimes I see a list of requirements that need approval, but most of the time I just see a total number and an Approve All button. If I click Approve All, I don’t have a chance to review what I’m approving. How do I get a listing of what I’m approving without going into each individual scout’s rank advancement pages?”

There is not a way to export when in the den, just approve. I am the Cubmaster and have all the correct admin permissions in the unit roster. I have checked and it is not assoicated with our AOLs only (who are bridging) but other dens as well, so the answer that they are associated with a former unit does not apply.

Why can we not export a report for both the needs approval and needs awarding from the den level. The title clearly says “report” yet there is no export button we we can email it out for DL/parent review.

Thank you
James
needs_approval_issue

James, please try re-setting your Pack Admin role:

  1. Go to your Pack Roster page in Scoutbook.
  2. Click on your name.
  3. Click on your Pack Admin role.
  4. Make sure the box is checked next to “Position Approved”.
  5. Click Update.
  6. Then log out of Scoutbook and log back in.

Do you still have the issue?

Hi Jennifer,

Thank you for that. I had already checked on this. As I stated, that is not the issue.

Yes, Position Approved is checked. I have logged out and back in. Also, there is no end date (which there should not be).

@JenniferOlinger’s request was that you try a specific way to “reset” the admin role. This is distinct from checking whether or not it appears to be correct. You may have already executed the “reset” process, but it isn’t clear from what you posted that is what you meant.

Sometimes, despite appearances that everything is correct from the front-end, there is a back-end issue that causes the admin role to become “disconnected” for lack of a better description. There is no obvious indicator that there is a problem, and if the steps are not executed exactly as noted, the “reset” is ineffective. I’ve had to do this myself this several times as a Unit Admin. It’s generally my “repair procedure #1” when things don’t appear to be working as expected. Sometimes, it doesn’t resolve the issue. Other times, it resolves the apparently-unrelated issue entirely.

1 Like

Clearing browser cache and cookies can sometimes help, too.

1 Like

Thanks Jennifer.

I had tried that as well. Restarted the computer. All the typical. I still get the same screen without and export from the den area.

James, which browser are you using?

Do you have the Feature Assistant Extension for Scoutbook enabled?

Jennifer,

Chrome.

Have not heard of Feature Assistant. Just looked it up and it is not ScoutBook but an add on by a volunteer. Are you asking/stating that I should have that added onto Chrome to get the den export to work and it is not a standard feature of ScoutBook? Thank you.

I was just asking if you had it enabled.

I am trying to reproduce your issue, but have had no luck so far.

Thank you for trying.

@JamesWinslow I will send you a direct message > look at top right Avatar to find it > it will be a green dot with a number 1 > it will be a private message channel with select members of the Scoutbook User Advisory Council (SUAC)