Training Quick Search not working for Member ID

The Quick Search feature in the Training Manager has recently stopped working. If I search for the Member ID, I get an error that “FirstName or LastName shall be passed”. The FirstName and LastName fields are grayed out. I’ve tried on Chrome and Edge. The “Member ID” search is an “or” function and has always worked by itself.

I just tested, using MS Edge, private browsing window, and it worked just fine. (BTW - it is greyed out until the list has loaded completely.)

I’m seeing the same issue as the OP when searching by BSA Member ID at the unit level as a unit Key 3 Delegate. I verified it with several different BSA IDs from my unit, including my own.

I can find my record (and others in my unit) using Quick Search with name information only.

The “grayed out” fields, however are editable as long as no BSA Member ID has been entered (or if you hit the “clear form” button after entering info. Similarly, once you start entering data in the “name” portion of the form, the BSA Member ID grays-out as well.

I see the same behavior in Firefox, Chrome and Edge (all current versions), in both regular and incognito/private browsing windows, with or without cache cleared. It seems like it’s some sort of permissions issue, rather than something browser-specific.

I get the same error message as Dennis and Charley when using “Quick Search” using the “Member ID” option.

1 Like

I have reported this to the BSA IT team

1 Like

Here is the update: “Thanks for bringing this to our attention. It has been resolved. Please know that, due to PII concerns, a change has been made to the Quick Search – it now requires entering a first or last name when searching by Member ID.”

1 Like

Thanks to you and the team for such a quick turn-around. Looks like it’s working as specified for me now.

One non-urgent suggestion. The error message when you don’t enter the search target’s name says “Enter your name”. It should probably say “Enter the person’s name” or something of the sort. The user could get confused and think they are meant to enter their own name (e.g. to validate that they have authority to search), and then get a failure. I knew what they meant, but I’m also used to navigating oddly-phrased instructions for work. :^)

Thank you! Yes, that works now.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.