Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Troop/Crew Selection Button

I noticed an issue on the web page for scouts registered as both troop and crew.

To switch between them, you can click the troop or crew number in the center of the screen. If you click on the troop number while looking at the scout’s troop record or crew number while looking at the scout’s crew information, the page flashes briefly and is then blank. The links at the top no longer work either: Quick navigation, go back, home, my dashboard, troop, and roster don’t work. The way to get it to show again is to go to the address bar and hit enter to reload the page.

@LeslieHolloway - just tried that with my son and could not replicate the behavior on my phone. Will try the pc and several browsers and report back.

Thanks for trying. I should have included the platform I’m seeing this on. I’ve reproduced it with Chrome, Edge (the original, not chrome based), and IE on a Windows 10 PC and with Safari and Edge on iPhone. Occasionally it doesn’t happen the first click but then does on the second.

@LeslieHolloway - thank you for your update. I have tried on my android phone, win10 pc with Opera, Edge, Firefox, Chrome and SeaMonkey and could get the same behavior for my son’s account. I then tried with the other dual members and indeed replicated the issue. I did find however that if you click the browser refresh button it normalizes and presents the pages and all buttons work. So it appears to be a cache issue. What you can do on the pc is open the developer mode in the browser and see if you spot the fault. But certainly the browser refresh button fixes it.

Starting with a loaded page and then reproducing the issue gives one error in developer mode in Chrome (below). Starting with the error and refreshing gives several warnings I’m not including.

mobile-concat.js:26 Uncaught TypeError: Cannot read property ‘_trigger’ of undefined
at Object. (mobile-concat.js:26)
at h (mobile-concat.js:2)
at Object.fireWith [as resolveWith] (mobile-concat.js:2)
at Object.r. [as resolve] (mobile-concat.js:2)
at HTMLDivElement.w (mobile-concat.js:26)
at HTMLDivElement.r (mobile-concat.js:3)
at HTMLDivElement.dispatch (mobile-concat.js:3)
at HTMLDivElement.v.handle (mobile-concat.js:3)

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.