Unable to add Scout Membership Card to Apple Wallet via Safari API in new mobile app

I won’t post my card’s API link that I was able to quickly grab when trying to install the pass to Apple Wallet, but basically in the last two versions of the MyScouting mobile app, the app won’t install passes through the WebKit API link that is provided when clicking Save to Wallet in the app. At first I thought this was a quirk for having a jailbroken iOS device, but I tried on another non-jailbroken device and the same problem occurred. Being unable to downgrade to a usable version of the app because of a server-side block past the last two updates, this feature is now entirely broken. For app developers and support, I can DM my pass’ API link for testing.

YIS,
Matthew

1 Like

If you figure it out can you post? I’m not sure if it’s just MyScouting or my new iphone 12. I can’t add to apple wallet from any app right now.

It’s definitely the recent updates to the MyScouting app. A new iPhone has absolutely nothing to do with it, I’ve tested on multiple devices across both compatible versions of the app, jailbroken and unjailbroken.

It’s been reported and developer working on a fix. Hope to push a new build with the fix soon. Thank you.

3 Likes

I tried it, and got a wall of gobbledygook text in my browser when I tapped the “Save in Wallet” button.

It happened for both my IDs – Merit Badge Counselor and Chartered Organization Rep.

I just tried this on my iPhone and it says it “it can not be installed to the passbook right now” after clicking Save in Wallet

Yes it seemingly broke again…

I couldn’t get it to work on the iPhone. I have done it in the past, but I don’t see much point in it. Have you used for something useful?

I just like keeping a copy in my digital wallet since that has replaced my need for a physical wallet for everything except my passport and licenses.

1 Like

That is why I loaded it too. I was wondering if any councils found a good use of the bar code on it.

Update I got this to work randomly this morning. Note the Membership pass found in the Scouting app (not the My Scouting app) is still broken.

Hi Matt. A new update is available for download with fix for the membership card to wallet issue. Thank you.

It worked! Thanks! I always picture a check in somewhere using the bar code, but not yet.