Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Unable to Submit Adult Application

Hello,

Hoping someone in the Advisory Council can provide assistance… I have an active Scoutbook/my.scouting.org account, I can access it without issue and have confirmed my that my profile appears to be populated appropriately. Admittedly, I’m a novice user of the my.scouting.org ecosystem of pages.

I am attempting to apply to a committee position with my sons’ pack, I’m already associated to the pack in my.scouting.org. I have followed the links in beascout.scouting.org, login using my BSA account, navigate to the relevant pack’s application page and select the adult application, but the fields on the form for my name and birthdate are blank and cannot be edited, so I am unable to proceed. It appears there is something on the back-end that is not pulling my information from the main database (or maybe some simple trick I’m missing)?

I’m at an impasse and unsure how to proceed, does anyone have any insight as to what is causing the issue and how to resolve? Thanks in advance for any assistance, username: mitchellsharp

Thanks,

Mitchell

what is your BSA# and I can look at a thing or 2

Screen Shot 2021-05-01 at 11.08.19 AM

IF I had to guess it might be your monitor - BSA likes to use 20% grey which is sometimes nearly invisible - BUT you see the green check on far right side

BSA# 135681714

The field is definitely locked… Unfortunately its not possible to include the cursor in a screengrab, but when I hover the cursor over the name and birthdate fields, its replaced with the general prohibition symbol:

Sorry about the exhaustively large example, here’s what my actual screen looks like:

are you sure you are logged in - might look different as you have not has a criminal background check - but that is a pretty different screen from what I see

Check the Your Profile page in my.Scouting. That should have a name field you can edit, and that syncs into Scoutnet and Scoutbook. Is it blank there as well?

Definitely logged in. On my profile page in my.scouting.org, the name fields and birthday are populated, but also not fields I can edit, exactly the same as on the scouting application (with the exception that the fields are blank on the application):

image

I am attempting to register as a Committee member in a Unit, and am experiencing the exact same issue, with two differences.

  1. I am not already registered at the unit I am applying to. At the Council, I am registered as an Asst Council Commissioner and Council Key 3 delegate. At the District, as a Member-at-large and an Asst Dist. Commissioner. I am not registered in any unit at this time.
  2. On my “My Profile” page, these fields are also populated however I can edit my name, just not my birthday.

In the application for the unit (I obtained the link from Invitation manager) I am able to fill in all fields on the first page except my name and birthday. It will not let me continue as these are required fields. I get the same universal stop icon when I hover over these fields.

I contacted our Council registrar and she said she would open a ticket with National. Have not heard anything back yet.

Any help or insights would be greatly appreciated.

1 Like

Just wanted to update this post. I had not seen any further updates or suggestions posted.
The problem, at least in my case, seems to have been resolved (or resolved itself). :+1: :smiley:

I’ve been re-trying daily to see if it might have been a server propagation issue or something, even though there were no recent changes to my registration.
The problem was definitely not a monitor issue, nor not being logged in, nor not having a CBC. It appeared that the information that should have pre-populated the multiple application was simply not carrying over.

Today I tried again and everything worked as it should.
The Sun is shining, the birds are singing, and as is well…

If anyone did anything to help this along, Thank you!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.