"Unable to update adventure Requirements. Please try again later"

When trying to log completion of adventure requirements in the app, I persistently get “Unable to update adventure Requirements. Please try again later”.

Please believe me: I have tried later many, many, MANY times! The error is persistent, regardless of which requirement I try to mark complete for my son.

I checked and found similar topics in the forum (like this one and this one), but the topics have been closed automatically without offering any guidance or solution.

I have tried all the basic troubleshooting: deleting cache/storage and uninstalling/reinstalling the app.
None of this helps. The situation is profoundly aggravating.

Could someone on the forum please help/advise?

Trying to narrow down potential causes, is the issue unique to the app (i.e. you can
successfully log advancement by going to https://scoutbook.scouting.org and logging in), or are there issues in both the app and at the website?

If you post your scout’s BSA ID (no names please), the Scoutbook User Advisory Council folks may be able to do some additional troubleshooting.

Hi! Thank you so much for getting back to me – Much appreciated!

I tried logging in through https://scoutbook.scouting.org and marking advancements as complete and it worked just now.
(Why on earth is there no link to this ScoutBook when I log in to https://my.scouting.org/ ?!?!?!?!?! – At least it works, even if it is clunkier and slower than the app or the advancements website)

If it helps with troubleshooting, the Scout’s BSA ID 135683912.

Glad to hear that you can at least get things entered, even if it isn’t through your preferred interface.

I couldn’t tell you why the BSA hasn’t included a link to Scoutbook from my.scouting, but I can see there might be some value there. I suspect recommended changes to my.scouting have to go “up the chain of command” through council, but there might be a route here in the Scoutbook new features request, but that is really more focused on Scoutbook itself.

It sounds to me like it’s an issue with the app itself, since the web interface worked. I know that the folks from SUAC monitor the forums pretty closely, and they can contact developers, so they may be able to get more details on what’s going on.

Out of curiosity, who/what is SUAC?

Sorry. I forget that I’m speaking in acronyms sometimes. SUAC is the Scoutbook User Advisory Council, a group of volunteers who support the other volunteers (and professional scouters) who use Scoutbook. They have more access (to varying degrees) to the back-end through tools not available to the volunteer scouters in general.

They aren’t the software developers (BSA has a separate professional IT/developer staff), but they were selected by the BSA to provide support to the folks using Scoutbook, and most have done so for many years now. They have been doing a great job (in my opinion) of getting us as users answers to software questions (to the extent BSA permits them to share information), and carrying our concerns/suggestions related to the software back to the development and BSA staff for consideration, all while juggling their real jobs and “normal” scouting volunteer roles. They put up with a lot of flak from the user group, generally because of frustrations with decisions they aren’t making, and for which they can’t explain the reasons even if they have been given them.

The app mentions reporting issues to ScoutbookAppSupport@scouting.org – would that go to the volunteers at SUAC or to the separate professional IT/developer staff? I emailed them regarding app issues on May 3rd, and I haven’t heard back yet – Of course, this would be understandable if that address is monitored by the volunteer folks, whom I commend for all the effort and time they put in to help the community.

That’s actually a good question. I don’t know, but the SUAC folks might.

The SUAC definitely does not have access to that email inbox. I’m checking whether IT still monitors it.

In general, support for the app has dwindled significantly with cutbacks in recent years. I recommend staying away from it.