Add Leader / Scout option gone from 'Pack Roster' page

Not sure if this is a known recent bug, or some artifact of ongoing rechartering, but the option to add Leaders or Scouts from the My Dashboard → My Units → Pack Roster no longer is present.

I have ‘Pack Admin’ Scoutbook rights, which hasn’t changed in years.


First guess is resetting your admin role - Go to unit Roster > Click your name > click Admin > click Update - that might solve it

Weird: None of the names within the Leader section are clickable, but all Scouts are.
Tried doing it through My Profile → My Scouting positions, but none of those are clickable too. Pack Admin role is still listed under ‘My Current Positions & Roles’.

Closed browser, even tried running in Firebox Private Mode too.

EDIT: Tenure shows as 0 days.

@MartinLeach follow my instructions above - go through Roster NOT Profile - that is the only way to do it yourself

I did go through My Roster: ‘Weird: None of the names within the Leader section are clickable, but all Scouts are

What’s interesting is that my tenure shows 0 days, rather than the 886(ish) it should be going by one of the position roles.

I am wondering if your issue might be related to your pack’s Recharter not being fully processed yet.

After it is processed by your council, I would recommend having one of your pack’s Key 3 (Cubmaster, Committee Chair, or Chartered Org. Rep.) add you as Unit Advancement Chair or Key 3 Delegate at my.scouting.

That could be it. Our committee chair has submitted the rechartering info, but our district hasn’t yet processed it.

I’ll wait until it’s all done and regroup then. We have a couple of other issues going on, which could well be rechartering related.

Thanks for all the answers. I’ll close this, and follow up in the future should we still have issues post rechartering.

@JenniferOlinger - I just checked for the functional roles and the Advancement Chair is still holding steady in that position and we are a 12/31 expiration. @MartinLeach - what do you show in when you click on the icon in the upper right where your name is > click on my profile then scroll to registered positions ?

Right, I see Martin as a Unit Advancement Chair in Scoutbook, but not my.scouting. I just see his registered position at my.scouting – no functional roles.

@JenniferOlinger - ah… I mis-read that part about adding the functional role. I suppose as an interim fix a unit admin could grant full control and or unit admin unit the recharter dust settles.

1 Like

We’re going to let the rechartering dust settle before looking more into this.
I’ve changed roles a couple of times within the past few months (ACM → Webelos Den Leader & Advancement Chair), and we’re also correcting a bunch of leader & roster information too.

Thanks again!

@MartinLeach Martin, please give it a try now. I tried something that might fix the issue for you.

@JenniferOlinger Still the same.

Don’t worry about spending time on this. This all came about when trying to add an existing adult as a Den Leader. She’s been a registered leader since 2018, her Scoutbook Den Leader position was somehow removed, but it’s not letting us re-add her back.
However, we can live with this issue until rechartering has completely finished.

Thanks again.

@MartinLeach What is her BSA member number? Her issue might be something else.

12859535 if you want to have a look…

@MartinLeach that BSA # has never had a registration

Have a Key 3 go to and look at official roster

Oh whow! Thanks for that info. I’ll have to chase that up asap then!

I found an expired Tiger Adult Partner registration for her under BSA member number 135624593 (also middle name is spelled slightly different). However, Lion and Tiger Adult Partners are not considered adult leaders by the BSA.

She will need to be registered as an adult leader before she can be added to Scoutbook as a leader.

@MartinLeach so you see +Leader? it just was not functioning in this instance - not quite how it was presented to start with