Pack Admin - Lost Functionality

Hi Team
Can you please review my Admins status? I am still the Unit Admins for Pack 0545 Broomfield Colorado, however I now see that I no longer have full control for some scouts and 0 ability to assign leader positions to existing leaders on the roster.

Is this an issue or new functionality?

Here is my info
SB User ID:
BSA Member ID:


The following assumes that your registration as a scouter is still current. To verify that, check your registered positions at my.scouting.

Sometimes the Unit Admin position gets “glitched” behind the scenes. Try going to:

Scoutbook → My Dashboard → Administration → My Units → Unit # → Unit Roster → Your Name

then select the Unit Admin position. Make sure Position Approved is checked, then click the red Update button. That frequently resets the Unit Admin role behind the scenes. The “fix” is path-sensitive, so you can’t go through “My Positions” to try it.

If that doesn’t work, ask one of the other unit admins/unit key 3 to re-approve your Unit Admin position.

Thank You. I tried going through the path, when I got to the roster and my name it is not clickable, nor are any of the other adult leaders.

I will reach out to another unit admin to see if they can re approve my admin position.

Weird. Your registered scouter position is current when you check at my.scouting, right? If not, you won’t be able to be assigned a leader role in Scoutbook until that gets fixed with council.

That could be the issue. My registered position in my.scouting is Assistant Cubmaster, however I am not in the position now. I am a Den Leader, Assistant Den Leader and a few other roles.

The bigger issue is whether you’re currently registered, than necessarily the specific position in which you’re registered (at least as far as functional roles like Unit Admin go). It seems (from the outside) like another unit admin/Key 3 (CM,CC,COR) should be able to get your admin role re-approved if your registration is current. If that doesn’t work, please post back and the SUAC volunteers may be able to help with further diagnosis.

Yeah I should still be current and registered.

Thanks again for all your time and help today. I will see what the key 3 with the Pack can see and go from there.

Quick update. I had the cubmaster reset my admin access and that seems to have solved some of this, but I think what I am seeing now is an actual bug within Scoutbook.

If I am on the ROSTER page, all the adult leaders are grayed out and I can’t click into them. But from a Den level I can access the leaders and their names are in red and clickable.

Also the ROSTER page in our instance is very slow to load and has been timing out.

Here is a screenshot showing how all the leaders names are not clickable.

This is how the entire roster looks leaders.

NOTE, that I did color out the last names of the other 2 leaders in this example for privacy.

Can you log into with the same username you use for scoutbook. Click menu > my profile. Scroll down and get a screen shot of your registrations, including any functional roles.


Nothing looks especially wrong. I requested a position sync that should happen later tonight. I also noticed a couple of your past scoutbook positions that hadn’t been approved. Could you try approving those. Other than that, I know some of the APIs have been acting up. It could just be that the check whether you are actually registered is failing and this stripping your permissions. The developers are looking into these issues. While your issue sounds similar, I’m not certain if it really is the same or not.

Thanks Jacob!

Things look to be back to normal. I will keep an eye on it.

I appreciate you and Charley for all the help!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.