Advancement Chair does not have "Full Control" of scouts

Since our troop’s last Court of Honor I have lost Full Control for many, but not all of the scouts in our troop. Who can help with this? I have tried to resolve it with help from our troop leaders but we have not been successful.

There are a couple of things that can cause problems with connection permissions. Some of this will probably be duplicative if things you’ve already done.

One can be if something gets messed up with your official registration (e.g. YPT expiration, registration lapse, unintentional creation of a duplicate account). Have you verified that your registered position at my.scouting is current, as is your YPT, and that your BSA ID on the Scoutbook account matches the one on your registered position at my.scouting?

Did you previously have the functional position of Unit Advancement Chair assigned through the roster manager at my.scouting? Is that still currently appearing in your positions at my.scouting?

If your “Full Control” was assigned as part of being a Unit Admin in Scoutbook, it could also be a glitch in that position. Have you tried going to
Scoutbook → My Dashboard → Administration → My Units → Unit Roster → your name

then select the Unit Admin role, make sure the boxes are ticked and hit the red button at the bottom to accept the position? Sometimes the role gets messed up behind the scenes, but looks fine when you check. The “fix” is path-dependent, however, so it can’t be done via My Positions.

@SeanMcClain I see no registration for you as an adult leader under this login. Have you filled out an Adult application?

your registered number is 13020780 - that is now back in Scoutbook so your admin will be able to re-establish connections

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.