Advancement Coordinator permissions, again

I was recently asked to serve as the “advancement coordinator” for my sons’ troop. As relevant to ScoutBook, I understand that I will need “View Advancement” and “Edit Advancement” permission for all boys in order to carry out my duties in that role.

On Monday this week, the Scoutmaster added a Position of “Unit Advancement Coordinator” for me in Scoutbook. (I was already registered as a committee member, also as a den leader in a pack and as a Merit Badge counselor).


However, when I go to the list of boys in the troop and try to browse into any other than my own sons, I still get the message about “You are currently not connected to this Scout.”

I pointed the Scoutmaster to a previous thread, Advancement Coordinator , about a similar problem in a Pack, and he says he did something to fix it, but still no luck.

One other thing that may be relevant: when I actually browse into the new position in the “My Scouting Positions” screen, I notice that the “I agree to join the unit leader roster” box is unchecked. When I check it, click “Update” to save, and go into the screen again, I notice that it’s still unchecked.

BSA Member # 12302388, ScoutBook UserID 2418316.

@DavidLambert your Troop Committee Member position and Advancement Chair positions are unapproved - an admin needs to approve them as a start to fix this

1 Like

I also recommend a Key 3 member (Scoutmaster, Charter Org Rep or Committee Member) go into, go to Roster then Position Manager, click on Functional Roles and add you as Unit Advancement Chair. After 24 hours, this will give you the proper connections in Scoutbook and allow you to access Internet Advancement.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.