Advancement History Report does not match

When I generate “Advancement History Report” for certain scouts, it does not show their current rank.
For example, one of the scout is “Second Class Rank”, but the “Advancement History Report” only shows his Scout achievement date. It does not show Tenderfoot and Second.
This is happening to multiple scouts in our troop when I generate the report.
[Initial roster view shows that a scout is Second Class, but report only show Scout rank on second screenshot.]

If you could post the BSA member numbers of some of the Scouts (no names please), we can take a look.

These are the two, but it’s also happening to more scouts.

Their ranks appear as Completed and Awarded, but not Approved.

They show to be approved. For awarding, I used “troop report” to mass award the ranks & merit badges.
Does that have to do anything with it not showing up as approved?

Just to verify… when I ran the report back in 1/20/2021, it was actually showing Tenderfoot.

Issue figured out how to resolve.

  1. I approved the Tenderfoot & Scout Rank via Internet Advancement.
  2. If I go thru Troop Report to mark Rank as “Awarded” then it resets all previously non-awarded approved ranks as non-approved.
  3. I went back to Troop Report menu and found that previously approved Ranks were all marked as non-approved.
  4. I ran Troop Report to mass mark all as Approved Rank and now it generates the report correctly.

Thank you.

1 Like