Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Advancement Report Will Not Load

I am the advancement chair for a Cub Pack. When I press “Advancement Report” from a purchase order, the new window appears, but nothing loads. Is there a known bug?

I’ve been generating the Advancement Report this way for almost 2 years. It’s happening for both my current, open purchase order and closed, historical purchase orders.

Hope someone can help. Need to purchase Bobcat rank badges by Thursday! :slight_smile:

What browser are you using?

Jessica,

Go to My Dashboard -> Administration -> My Account -> My Positions and make sure there is a green shield with white check next to your position in the unit. I am able to generate the Advancement Report for my units.

I’m using Chrome browser.

It is also working for me.

Something else to check: Make sure that you are connected to all Scouts in the unit. You might not be connected to a Scout, and that might be the issue.

Yes, the green shield is marked for these positions:

Pack Admin
Unit Advancement Chair
Committee Member

go to unit page > roster > click your name > click Admin > click update - then try advancement report again

The connections manager shows I have full control for all scouts. We are working an issue where we have a duplicate and one scout not syncing (waiting on BSA number). But those issues were present last month when I successfully ran Advancement Report last. Hmm.

Tried clicking “Update” for my Pack Admin role. No change. :frowning:

Jessica,

Did you use the path that Donovan indicated to update the Admin role? Going from My Administration -> My Positions does not work the same way as unit -> roster -> your name -> admin -> update.

Yes, I did it through Unit > Roster > Name > Admin > update.

Try logging out of Scoutbook, then clearing your browser’s cache and cookies.

Just tried your suggestion. Still have the problem.

BUT…while I was clearing cache, cookies, and rebooting, I tried to generate the Advancement Report from a mobile device. Success! So, I think the issue is my PC or browser – not with Scoutbook. Thanks for the ideas…I’ll keep plugging away at it, but for now at least I can get to the scout shop.

@JessicaCollins - cool. Now to narrow down the issue on the pc. I typically run 6 or more browsers on my pc to check how each handles the css, report rendering etc. I gather it has worked in the past? There are oddly enough times when the temp file generated reaches an OS max limit. That is especially true with outlook if the same file is sent over and over again… it will break when the tenth file is opened.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.