Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

API Error When Transfering Registration

When I try to transfer my son to another pack, I am getting an error about not being authorized to access the API. I have tried multiple times for the last two weeks on mobile, and multiple desktop computers using multiple different browsers.Screenshot from 2021-09-12 20-18-12

@DanielYeaw - I would most likely do what the Message instructed- contact your local council. There is potentially some data missing that dies not properly link you to your scout.

Or, your Council doesn’t support online registration & transfer.

Thanks, I’ll give my council a call. This is a pretty bad website experience to be honest, websites shouldn’t be returning API errors to users. If information is missing or council support is missing, the website should tell the user that way before you go to click on Submit Transfer.

I have also shared that we had this error pop-up on Sunday with BSA IT.

Hi @RonaldBlaisdell, thanks for letting IT know about the issue.

I wasn’t able to get a hold of anyone from the Council today, but @BrentRichards had the idea to try with my wife’s account, since she was the one who originally registered my son. That worked great.

If anyone sees this API error in the future, it may be because of a parent registration vs. transfer attempt mismatch.

3 Likes

@DanielYeaw - seems like I was on the right track

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.