App requiring update and won’t open

This morning, tried logging into the Scoutbook app. Once it opens, I get a message that it needs to be updated to v2.4.20. After I updated my app, it now says I am on v2.4.0 and says that I need to update. I can’t get past this. I have confirmed similar results from others as well. Currently, can not use the app.

FYI - I am using an iPhone 12 Pro Max on the latest operating system.


@JohnBowman2 I sent this to developers

1 Like

This is my version

I can’t even get to settings. It stops at the screen that says I need to update and doesn’t progress beyond that screen


@JohnBowman2 - I would try an uninstall the re-install.

it is a bad build - DEV is working on it


I have tried twice. Uninstalled and reinstalled. I have also rebooted my phone. No luck. Application still won’t pass the screen to update the app shown above.

@JohnBowman2 - alrighty… at the very least the team has been notified.

1 Like

Same here.

I’m having the same issue and tried to reinstall twice.

The fix has not yet been released.

Something to consider… I had many issues with the scoutbook app when first trying to use it. I was told by our very experienced troop leaders to use the website instead of the app. Seemed counterintuitive as I thought like the app would be the best way to access but I’ve have no problems since switching to the scout book website. It’s a bit slow at times but solved all the problems I was having with the app.

There is some functionality that doesn’t seem to be available in the app but it does seem to be getting better. With the fix now in place, it seems to work better and is faster. That said, for some things I still go to the website.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.