login missing google button

When using, after you complete step 1 for registering a youth it asks if you have an existing login. If you answer yes, the Google login button is missing on the modal that pops up. Tried on chrome on iPhone, chrome on windows, and edge on windows.

A workaround is to log into my.scouting first and then click the link to the unit registration page.

Thanks Jacob, however I tried this and it did not work.

@JonathanSmith13 - is it possible to do this on a pc rather than a phone

Tried on PC in both Edge and Chrome (button missing and pre-login doesn’t work)

I opened this topic more to make the development team aware so they can hopefully fix it. If I opened this in the wrong place, I would love some help on where to report this bug properly!!


I suspect that the most effective way, if potentially not the fastest way, is to push this issue up the chain via your council professionals. Ensuring smooth and easy applications for new/renewing scouts and scouters is to the direct benefit of the local council, and council professionals have ways to file problem issues with national staff that are not available to volunteers.

I logged in this morning, and the Google button was present. I suggest you clear you cache and access the site via an “Incognito” window in Chrome, or an “InPrivate” window in Edge.

1 Like

@RonaldBlaisdell Others have reported this too. When you tested, did you go to beascout, start applying, fill everything out and then get to the login screen? That’s the process being described.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.