Cannot Register New Scout with Linked Google Scouting Account

I’m testing out our parent’s ability to register new Scouts who have older siblings already in Scouting.

Parent’s don’t seem to be able to Sign in with Google to complete the registration, the image for “Sign in with Google” doesn’t appear.

Steps to repeat:

Step 1: Navigate here: My Scouting
Step 2: Choose Youth
Step 3: Fill out the Youth Information
Step 4: Login to your account using Google

Screenshot below, please advise.


(If you click the “Use Google or Apple Login”, it takes you to a PDF which describes how to link your User/Pass Account with Google/Apple SSO.)

What happens if they go to my.scouting and log into their account as the first step?

Just tried that… After logging in first, it “pre-filled” my information immediately, not even providing the option to login. I was able to proceed to the checkout page.

That’s definitely a viable work-around, but a little complicated to try to explain to families.

It looks like the “sign in with Google” button is missing from your screenshot. Did you try refreshing the page? Or maybe clicking where it should be (to the left of “sign in with Apple”)

I tried refreshing the page, clicking left of the Apple button, clicking all around.

The link appears to be missing.

What browser are you using? Have you tried a different browser or device? Or incognito?

Chrome Version 114.0.5735.199 (Official Build) (64-bit)

Here’s following those same steps in an incognito window:

Can you follow the steps and confirm you’re getting the same issue?


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.