Buttons haven't been working for weeks

I have been trying to enter all of my new Scouts’ achievements into Scoutbook. For the last month, every time I click an achievement, instead of going forward, it goes backward to the den. I can’t enter anything because they won’t open. I tried updating. I tried using multiple browsers. I tried using the mobile site. Everything just goes backwards.

Important to mention that it seems to be only the new Scouts. But I have full administrative control over them, so it’s not a permissions issue.

@AngelaChidester - could you check the membership section of each of these scouts ?

Yes, I can see membership and connections.

@AngelaChidester - what does it show in the membership section for current membership ? I gather these are brand new scouts…A unit admin may need to reset your den admin role.

Their membership is current, their active den status is current, and all connections are active.

I am able to enter achievements if they are just a checkbox (like all Bobcat requirements).

Anything with a button to expand to a list of achievements goes backwards.

@AngelaChidester - does it show like this in membership

I would ask a unit admin to reset your den admin role especially if they are brand new scouts

and you mean this in their advancements


Yes, it does. Like I said, everything is active, accurate and up to date.

I can mark completed all checkbox achievements, but nothing with a button/expandable list.

@AngelaChidester - what do you mean by button expandable list… you have lost me

I can check off the ones at the bottom that are visibly active individual achievements. See bottom.

The buttons at the top that would go forward to their list of individual achievements (Baloo the Builder, for example). No matter where I push them. The box, the center, the red arrow… They go backwards to the main screen.

@AngelaChidester - I can do a screen share if you wish

Can you post a screen shot of all current memberships for one of the scouts in question?

1 Like

I can’t do a screenshare at the moment. For some reason quick entry is working. I’ll survive with that for now. I’m hoping it’s just weird glitches. I was hoping I wasn’t alone.


Do any of these Scouts have 2 pack memberships in the current membership section? If you post the BSA Member ID (no names) of one or a few Scouts we can look.

Scoutbook does not like if a Scout has memberships in 2 packs and the den levels are not the same.

Nope. They are all new


Please give us a BSA Member ID of one of the Scouts you are having trouble with so we can check their record in the database. It may tell us why you are having a probelm.


Taking my Bear Den as an example, BSA members 140467990 and 140467785 have the issue. Members 14681743 and 140594551 do not.

For what it’s worth, I think it’s all of the kids who were registered online at our Recruitment Night that are affected. All new scouts who have joined since are not affected.

So, if it helps, that would be anyone registered on September 14, 2023


It appears these Scouts have the wrong member type in the DB. It was not anything you did but it is confusing SB. I’ll need to get the developers to investigate.

Thank you so much! I have been so confused.


This problem has been fixed. Please try again.