Calendar Format

The calendar format is not holding after it is typed out. It looks fine in the Old Calendar see attached. It is an absolute disaster. The deployment of the calendar in this way is not only unprofessional it is a failure of BSA leadership on multiple levels for allowing something like this to be deployed.


This is noted in several threads - it is actively being worked on

Thank you very much!

90% of the root cause is the Old SB Calendar being live and it messing up the new coding of events.

Hello, the calendar on IA does not allow me to select the “event type”. May I ask how I can resolve this, please?

@ElisabethKrause - what is your role in the unit ? Is that the selected role in the upper right of IA ?

Where it says add unit/subunit, are you selecting one or multiple units or subunits? Which?

Often a Shift + Refresh gets the Event type to load. That is being optimized in the future

I am an ASM with the unit (troop).

Two units, the two troops that I support as an ASM. Should I select one troop at a time when adding a calendar event?

I’ll try this next time. For this time around, I gave up trying to upload the event to the troop calendar. I am used to using the Scoutbook, just have to become better versed in IA calendar. I’ll get it right one of these days. Thank you!

What does that mean? Did someone else do it? Did you just leave one unit off the event? I’d definitely be curious about the results of adding separate events for each unit.

This is likely either a permissions issue of a bug that hasn’t been identified yet. So, I’m not expecting it to clear up on its own.

Are your two units a pack and a troop?2

I tried again, this type adding only one of the troops. I still cannot add the event. The box where “Event Type” is listed is highlighted in red but I cannot edit it. Here is a screenshot:

Only two troops at this point: Troop 10B and Troop 1010G. We’re in Singapore.

I tried this but it didn’t change anything. I still can’t add the event. Is there anything else I can try?

I didn’t think ASMs had calendar editing permissions by default. Are you also a Unit Amin, Key 3 Delegate, or have another role that has calendar editing privileges in the software?

If that’s the case, then that must be the issue.

I am a Unit Admin for both troops in Scoutbook, but no longer a Key 3 member (was in the past). I used to be able to created calendar events in Scoutbook. I’ll inform the troop that I am no longer able to do so. Thank you for clarifying the restriction.

Hrm. Unit Admins should be able to edit the calendar according to the help wiki:

Maybe navigate to your troop admin role via

My Dashboard → Administration → My Units → Troop XYZ → Troop Roster → your name

then select the troop admin role. Make sure the boxes are checked then save. Sometimes, the unit admin roles get “disconnected” behind the scenes, although they look fine from the front end. This trick resets them sometimes. It’s path-dependent, so you can’t go via My Positions.

@ElisabethKrause - what browser are you using? Any addins or blockers installed