Camping Log - cannot enter 0 nights

In an activity log for camping, I am unable to enter 0 nights as a value for camping nights. I was able to do this before. In this case a scout signed up for the whole campout but only attended Saturday. I want her to continue showing in the roster/attendance but not give her a camping night.

I first used the group setting to give everyone 2 nights, then went back it to individual to edit a couple of them. For her I entered 1 day, 0 nights, and it seemed to save it, but when I went back in it reverted to 1 night. Tried several times. It let me edit a different scout to 2 days, 1 night.

I have been able to do this (give 0 nights) in the past when we go “cabin camping” in the winter. I could create the activity log under “Camping” and give everyone 0 nights so those don’t get counted toward tent camping nights.

Is this a bug or has it been changed to disallow a 0 as a value. I would like to be able to do this - otherwise I have to create a non-camping event for a single scout and can no longer track our cabin camping events in the Activity Logs since the only choices are Camping, Service or Hiking.

Thanks for your help.

@ConstanceF

I tried to duplicate this on the test system and was able to record 1 Scout with 1 day and 0 nights. When I went back to edit the event, the 1 day and 0 nights remained.

Is this a campout linked to a calendar event?

Yes, I had not done that before. The calendar event ID is: 5583973

I just tried a camping log tied to a calendar event. Can you try again and make sure you set both Days (1st column) to 1 and Nights (2nd column) to 0? Not editing both days and nights will make the other change when saved.

Yes, set day to 1 and nights to 0 (see first screenshot). It seems to accept it - no error notice or anything. But after I save, it reverts to 1 night. (see second screenshot). It is the last record in the screen shots.


@ConstanceF - I would not have used the group entry as a data point. I would have just used the individual tab.

That worked. I deleted the event and started over entering everyone’s nights individually. Kind of a pain when almost everyone is the same except for one or two scouts, but it accepted the 0 nights that way.

Thanks

1 Like

@ConstanceF - my thought is that if the group entry tab is used it conflicts with the individual and i think there is a notice on that tab about its data

I’d say you were right except I was able to start with the Group nights - 19 scouts identical nights.Then switch to individual for two scouts who missed one or both nights. It was ok with a scout who had one night as opposed to everyone else’s 2, but did not want the 0 night entry. Anyway got this one entered - thanks.

That’s good info for the developers to try to track down a (kinda) special case bug. Thanks for providing the details!

I think they would have to turn OFF Group for the event once Individual was even touched

In that case, would the record retain what had been set-up in “Group” for the scouts, then permit individual entry editing for the “special cases”? Or would it default to 0/0 for everyone?

it holds the group and allows changes - but think - if any user clicked it back to group It would re-write

Yeah, that’s what I was trying to figure out. Seems almost like it requires either a lock-out (i.e. no more Group tab entry) or an “Apply to all” button for the Group tab (or similar) once the Individual tab gets used.

ETA: I kinda like the “Apply to all” button approach, since it theoretically maintains access, but requires active user intervention to “overwrite” the individual entries. It could even be provided with a warning notice pop-up if the individual entries are not all the same.

I’ve encountered that error before - when we logged a summer camp in 2022, most of the unit was in an Adirondack, and the IA activity log entry would not retain any youth who were credited with 7 days and 0 nights. That unit folded at last recharter so it’s not fixable now. (That unit only entered nights in a tent/hammock/open air, and not Adirondack or Cabin nights)

But recently I have had no issue when going straight to the individual tab and having 2 or 3 days and 0, 1, or 2 nights depending on the participant. I will get an IA app error sometimes where it will not allow me to click the green button to save, but that’s usually worked around by starting over on the event entry.