"No Camping Activities" on new event?

I have managed to create a new event and get the right attendees listed. But when I click on the event in IA calendar, the event details show “No Camping Activities” along with No Hiking Activities and No Service Hours. But I did add a camping activity. The camping nights show up correctly for each individual scout in his activity log. But they do NOT show when I edit the event - that shows 0 nights for everybody, both on group and individual lists. And the number of nights is not editable. It looks like you can change it, but when you go back and check, it has reverted to 0 for everybody. I’m using calendar only to track attendance, and this was really weird and awkward to create, and is now impossible to edit. What could be happening? Yes, I have done a hard refresh on every page. Thanks.

Is there more than one unit on the event? I know there have been problems reported with the logs in those cases.

Just one unit. It was a regular troop campout. These used to be quite easy to set up, but this time it seemed really complicated.

@WilliamFrench - you are not making a whole lot of sense in your post. Did you follow this

Or even better, how did you add the activities log entry

Apologies if my post did not make sense. I did not use the knowledge base in advance - I did not know about it. I have now read it. I think this may be an issue of an “activitiy” not correctly linked to an “event”. [As an aside, it is not intuitively obvious what the difference would be between an event and an activity. It is also not intuitively obvious where to find training on all this.

However I created this, and I’m sorry that I don’t remember exactly, I now have an activity log (which I think is linked to the event) that I am unable to edit. When I try to edit, it shows 0 nights camping for everybody, even though each individual scout activity log shows the correct number of nights. I can change the zeroes to ones and save without getting an error message, but they don’t actually change - going back to edit again, they are still all zeroes. There’s just some kind of weirdness going on which doesn’t make sense to me, and I can’t figure out how to correct. And that gives me a low level of confidence in the camping being recorded correctly, even though it looks right in each scout’s individual record.

Thanks for your time and any help anyone can provide.

Totally makes sense to me. Take courage, the app behavior is not enabling our units record keeping either!

Our unit is stepping back from these features for now.

We see:

  • camping nights reverting to 0
  • access to event and activity connection is not visible to advancement team
  • camping entries not visible after entry

Maybe the status of these issues is somewhere in the forums I will keep hunting.

@WilliamFrench did you add the camping inside the event or in the activity Logs

@WilliamFrench - in order to have the activity linked to the calendar event, you have to be past the event, then click edit event, click add camping in the camping section, edit the respective data for days, nights and attendees, then save, then save the event.

@DonovanMcNeil - i have worked through my instructions on a past event and worked through the add camping, and it doe snot show that i have entered it, but it does hit the activity log.

I don’t know exactly what I did every step of the way, but there’s some buggy behavior. Just now I deleted the camping activity from the activity log (where it looked like it was associated with the event). Now Camping Activity shows up under the Event in Calendar, where previously it did not. So deleting it made it show up. Hmmm. But I still can’t edit it. I think I’m going to delete the whole thing, try starting over, and just give up on understanding how all this is supposed to work.

Thanks to all for your help. Hopefully the developers will stress-test all this and figure out how to eliminate the buggyness.

OK, deleted everything and started over. Hopefully this bug will now be easy enough to understand. I successfully created the event and successfully added the camping activity. Then went to edit the camping activity. Under group, I put one day and one night for everybody. Then saved. Then went back to edit again, because two kids and two adults were only there for the day. I went into individual, and changed the nights from one to zero for those that only came for the day. Message: “Success! Activity has been updated.” But it has NOT been updated. Trying to edit again, those scouts with zero nights have been changed back to one. And each of their individual activity logs shows the camping night. I am unable to edit them back to zero nights.

@Stephen_Hornak did you delete the camping log?

the change in miles/nights/etc after a edit/save is a known issue with a story

@WilliamFrench Could you try changing it to two nights as a test?

@DonovanMcNeil , I am apparently encountering the known issue. I just deleted the relevant people from the campout, and will create a separate activity for them, something like “campout daytime only” that includes no overnight.

That’s a real problem to see “Success!” when you edit something, even though nothing has changed. It forces users to double check every edit, if they even know about the existence of the problem. We could mess up OA eligibility and Camping MB without ever suspecting anything.

Thanks for your help.

@jacobfetzer Creating a Fake Campout as a test and making it 3 nights, things appear to work as they should. I can give everyone 3 nights in group and save. Then go back and change some participants to one night or two and successfully save. They are still at one night or two when I go look again.

@jacobfetzer Further update: I can successfully edit a participant from 3 nights down to 2 or 1, but not 0. Apparently the 0 night campout is the issue. It is not uncommon for us to have people come just for the day. I would like to record them as participants in the activity, even though they have 0 camping nights.

One more piece: I found a campout in December, 2022, where we successfully recorded a scout as a campout participant with 0 camping nights (and 1 day). The zero nights shows up correctly in editing the activity, and also shows correctly as a camping activity with zero nights in the scout’s activity log. So this problem would seem to be newer than December 2022.

We had recently reported the zero nights issue to developers. I didn’t realize that was previously allowed though. We agree that you should be able to record zero nights, especially with the limited number of options for the logs.

@jacobfetzer One final thing. If I enter the number of nights using the “Individual” section, I can enter any number of nights I want for each participant. Including zero. The problem only seems to arise when I FIRST set everybody to one night in “Group” and then try to go back and edit some of them to zero. Start with “Individual” and you can put in zero nights for some people just fine. I don’t know what would happen if you tried to edit them later, but I don’t have any more time to play around with this.