Can login to my.Scouting via Apple Login and previously Scoutbook, but Scoutbook login no longer functions

Hi, I’ve been using Scoutbook for quite a few years. Within the last few days, I have no longer been able to access Scoutbook at all. When I try to use the app, I get a popup that says “Whoops! noUserId.” When I try to access the Scoutbook website, once I submit my login credentials the site freezes with a continually spinning icon. I can still access my.Scouting with no issues and also the myScouting app. I have been using Apple Login and have tried accessing from both Edge and Safari browsers and also an iPhone using both the apps and the same 2x browsers.

I have already tried a few troubleshooting steps that did not work:

  1. attempted to change login method back to Scouting credentials in the MyAccount feature of my.scouting. When I do this there is a pre-populated username that I cannot change as it is greyed out. Once I input a password; however, I get the message that the userID must contain 8-20 characters (no ability to change it).
  2. attempted to recover account using both recover username and recover password features on login screen. This sent me the username created by Apple, but does not help me get past the login.
  3. As I’m located in Europe with Transatlantic Council, I’ve tried logging in with (set to USA) and without a VPN (no change to European ISP settings).

I recently moved from National Capital Area Council (member # 135958901) to Transatlantic Council (member # 13978029).

Any help anyone can provide is greatly appreciated.

I sent you a private message so we can discuss you specifics of your issue. It is related to multiple BSA Member IDs. Click on the brown circle with white J in the upper right of your forum window.


I believe this is fixed. One of your old BSA Member IDs (MID) was placed on your Scoutbook account. I have restored your current MID so you should be able to login. I have asked BSA IT to investigate why the MID was switched on your Scoutbook account.

Thanks for the help. It does appear the immediate issue is fixed. I replied back to your DM–though you’d already fixed the access, I do have duplicate numbers that possibly could be merged to prevent any future issues. Thanks for helping so quickly.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.