Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Unable to login to Scoutbook but can login to my.scouting.org

Hi there,
Something happened to my son’s scoutbook.com account, he is no longer able to login to it. He can successfully login to my.scouting.org as well as the scouting app, but not scoutbook. He used to be able to login last year.

As a parent, I am able to login to scoutbook and view and update his profile/advancement. I even tried resetting his password, but all he gets is an error saying

“whoops! We encountered an error trying to process your request. Our webmaster has been notified and will fix it ASAP!”

Please help me out with getting this fixed.

This is a known issue and being looked at - if you keyboard refresh DURING log in you will get in - or go round about from my.scouting, to Internet Advancement, to Scoutbook

Thank you for the response, the refresh didn’t work for me but I was able to get in using the internet advancement route, thank you.

1 Like

Same here - unable to log in as the origonal poster had said; has this been fixed - the suggestions to fix did not work for me. Thanks for any help.

My son is having the same issue. Any update on a solution?

Yes. Fixed in tonight’s update.

1 Like

I just tested, the issue persists.

1 Like

@RahulNeelakantan - I suggest clearing browser history, cache and cookies. I did that and my son’s login worked.

1 Like

The login for my son works, however posting a note in a merit badge or advancement results in the whoops error.

@Stephen_Hornak

Does the notes whoops appear only for your son or for you as well?

@edavignon - just on his login

The same exact issue has been occuring for my son for the last week…and it isn’t resolved yet. The refresh doesn’t work. We can get him into Scoutbook by Internet Advancement on scouting.org

1 Like

once it fails go to https://scoutbook.scouting.org/mobile/dashboard/ and you will be in

It still does seem to be broken for my daughter. BSA ID 135751465.

We have reported this to the developers

3 Likes

Solution seemed to have been implemented a couple of days ago, but issue is now back with scouts being unable to log into scoutbook, but parents/scouters can.

1 Like

they thought they fixed it - but it is still an active story in development

2 Likes

My sons are having this same issue. Interestingly enough, I couldn’t log in under either of their accounts again this morning, got the “whoops” page, and then couldn’t get back to the Scoutbook home page. (Wouldn’t load when I tried to go back or enter the web address.) In trying to do so, I searched for Scoutbook on Google and clicked the various links to Scoutbook. After several more error pages i finally managed to get Scoutbook to load, and somehow ended up in his account. Now can’t get back into it. It’s been very frustrating for my son who has been trying to get things in order for his court of honor! Hoping it is fixed soon.

1 Like

You should take the back way into the system:

  1. Go to my.scouting.org and login with HIS account.
  2. Click Menu in the top left corner.
    3.Click BSA Web Links.
  3. Click internet advancement 2.0
  4. On internet advancement, click scoutbook in the mid left corner.
    You should now be in scoutbook.

Your work- around is appreciated, and will be helpful in the short term to enter his more pressing items. However, this is a complicated addition just to get to a process that already has numerous steps. It’s also been ongoing for 2 weeks or so now. Really hoping a solution is found asap, rather than a patch.

1 Like