Cannot Add Parent/Guardian Connection to Scout

We have a Scout (UserID 2797220) who has a Parent/Guardian connection on his profile. But when I click on the Scout’s connection, his mom’s connection displays “Pending.” So, I checked the box to “Send Invite Again” which the parent received. Nothing is happening when she clicks on the “Accept Invite” link. When the parent (UserID 2797223) logs in on Scoutbook, she doesn’t see her Scout on her Dashboard.

So, I tried to add a new connection to the Scout by searching with the email the parent uses on her Scoutbook (and MyScouting) account. Her account didn’t appear. I also tried searching by BSAID (13212064). No results appeared. This is even the same BSA Member ID that appears when I look at the profile of “pending” account connection under the Scout’s profile.

What am I missing here? The parent doesn’t have multiple BSA IDs. She can login on Scoutbook and My.Scouting. But I cannot add her as a connection.

Please help. Thank you.

The parent is connected and it is no longer pending - so something went right

I just sent another invitation. I will try logging out and logging back in.

it does not show as pending on my system

Weird. Logging out and logging in didn’t work. I did email our council about it. They must’ve done something already. I will check again in 24 hours.

Does the parent show her birth of date on your system? She is linked on Scoutbook now. Her son is transferring to a Troop. When I do the transfer, I get a Parent/Guardian Missing Date of Birth error. I notified the council of the birth date and registrar said she already fixed. But it’s still not working.

I sent you a private message.

It does take a day or so for the DOB to sync into the various systems before you can use the my.scouting transfer tool. If you’ve waited a day, do you still get the same error, or a different one?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.