Cannot Advance Dens as Key 3 Delegate

Should a Key 3 Delegate be able to advance a den?

I was able to advance the Webelos den where I have the Den Leader and Den Admin role, but I cannot advance any other dens in my pack even though I am a Key 3 Delegate.


@TimAbbott - did you select that role in the upper right dropdown. It would need to be a pack admin listed on the role

I see 2 parent roles and 1 Den Leader Role. In that Den Leader box it says I hold other roles but I do not see a way to change to any other role.

I do have Pack Admin rights though.

I was able to edit dens when that could be managed in Scoutbook but when it cut over the Internet Advancement I was no longer able to make changes.

@TimAbbott something is not adding up - I am taking a look

@TimAbbott are you trying to change for your den or another?

I’ve already changed my den from Webelos to AoL. I want to rank-up the other dens. I also want to remove the old den of AoLs who crossed recently crossed over.

And when school starts in July, I’d like to make new dens for any new Lions and Tigers.

well you have 2 den admin positions for the same den - which is redundant with the Pack Admin position (den admin gives you nothing in this case) - might want to end those

1 Like

@TimAbbott so how are you trying to advance the dens?

Either one of these two edit options. But they are only visible for the den where I am the Den Leader or for scouts who are in my den.

Scouts who are in NO den I can add to my den, but I can’t put them in any other den.

What if you click the 3 stacked dots by a scouts name in another den?

@TimAbbott try clear cache - Shift + Refresh - Incognito Window - - when staff signs on as you everything is good

1 Like

Clearing cache did the trick!

Thank you for your time.

I am also trying to advance dens:

I get different error messages on my Webelos → AOL transition:
Error with number - name

Tried number/name


Give it a minute and refresh. Possibly even log off and close the browser. I’ve see similar errors and found that it actually worked.


@JasonKracht - and do get rid of the “/”


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.