Cannot enter or edit data on Scout Page (Error Message)

yes, they are on my roster which is how I went and checked each of them

When I click on the names of the 3 scouts and ask to “edit profile”, via my.scouting.org I get the API error message or the page never loads. It only happens for 3 out of 36 Scouts on my roster

@MarkCorbett - this might be a stretch… but perhaps reset your unit admin role in scoutbook from the roster there > your name in the leader section > positions > click on unit admin > click update

On the my.scouting.org the system says I don’t have the “necessary permissions to access the resource”

I already did the update you suggested based upon input from Donovan McNeil

@MarkCorbett - I can set up a screenshare if you wish

Give me a minute to get my screens ready to save time.

I am ready when you are. How do we proceed?

I have remoted in and observed the API error noted on both IA and MYST. I logged in as myself and things function normally. We even ran an incognito window and same API error.

Here are the BSA # of the 3 Scouts where I am unable to update data or add training.
BSA# 133435097
BSA# 128300187
BSA# 133435206

This is the case for IA and my.scoutimng.org.

Thank you!

What is the API or can you get a cURL

I just did a screen share exercise with Stephen. Not sure what you mean by API, but the URLKS were confirmed

@DonovanMcNeil - the points of failure are:

In IA select a scout. Enter swim classification enter date then click save changes

In MYST training manager select program, training enter date for chosen person, click add person then in the child window click apply and that presents the api error there

Developers were able to get a cURL on the issue

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

@MarkCorbett Could you please check to see if your issue is fixed?

The API error is still there for the 3 Scouts I mentioned in my original post. See below for the Scouts BSA #s and the URL. The system will allow the update for swimming classification, ONLY after I exit and return, but I get the error message every time I try to update anything. Some changes I simply can not make… I have found it on 3 Scouts out of 37 on my roster.

The second picture shows where I tried to add training for the first Scout in the list below via my.scouting.org . I did everything correctly, but when I hit submit I briefly received the same error as when trying to update info on IA.

So the short answer: not resolved.

133435097 URL: Internet Advancement

128300187 URL: Internet Advancement

133435206 URL: Internet Advancement

Is there something you need from me?

Thanks for the help!

Mark Corbett
Cohen Issue 1
Cohen Issue 2

I now receive that same error when I open the Calendar page. Can enter data, but message is always present.

@MarkCorbett I have reported this to the developers.