Cannot enter or edit data on Scout Page (Error Message)


I am a Scoutmaster with full control. I have one Scout (BSA# 133435097) that I cannot update or edit his information. I tried to enter ILST for him and received the following message:
“Logged-in user does not have access to this API”.

I was able to update and correct accounts for all the other Scouts except this one.

Is there a fix? Thank you!

@MarkCorbett were are you trying? in for the true training entry?

1 Like

Yes. I don’t think these is functionality via Scoutbook, but that is the way I got to IA.

So I guess not really a Scoutbook issue? Just don’t know how to fix the API issue.

you could try 2 things - one try a hard refresh - press SHIFT and refresh page

Go to unit Roster in Scoutbook > Click your name > click Admin > click Update - that should solve it

Tried both, no joy! What next?

do you know how to turn on Developer tools to look at Network info of a browser

Yes, I found out how, what am I looking for?

I really do not understand what you are trying to do? Are you entering Camping nights?

Go to the Network screen and look for RED usually to see the failure

I am trying to enter his completion of ILST training (did this via Scoutbook, received error). I also tried to update his swim classification on IA and also received the error. He is the only Scout in my uniot that I can’t seem to add the training to his acount.

ILST would not be in IA - it would be under

1 Like

Correct. I meant

I went through Scoutbook to the training manager on and rec’d the error.

I am unable to even look at his profile via

@MarkCorbett - > select unit at left side > training manger > add/search on the left side > Add training highlighted at top > select program from drop down > next box select training > next box enter date > then below that enter name and click search > check box next to name > click add member

I did everything you listed. I looked at my entire roster and I have 3 Scouts that I cannot view or update their profiles (or add training, or change swim classification, etc) via I am able to access the accounts of everyone else in my unit.

@MarkCorbett - that is how you add training… there is nothing on the IA profile for training. IN the IA profile is the med form dates, swim classification, etc… it is not in

If all you want to do is add ILST then what I outlined will do it

Forget I wrote IA. I meant I successfully entered the training for 9 other scouts this morning. For some reason, there are 3 scouts on my roster where I get the API error message. The end result is that with that message I can not view or edit their profiles, enter training, etc

@MarkCorbett - are they listed on the roster for your unit in ?

For the 3 Scouts:

I can’t update swimming (rec API error) via
I can’t update training via

In both cases I receive the A{PI error message.