Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Cannot set Merit Badge Counselor Listing Preference to “Unit List” Part 2

We have similar issues to this prior post but with the Unit list name format always giving an error.

We have attempted the following but all give some type of error

Troop 0471 B
Troop 471 B
Troop 471
0471 B
471 B
Report :
Unit Lists: Troop 0471 B is not found. Make sure to use the official unit number.
Unit Lists: Please enter the units in the format Troop 0123 B, Troop 0123 G, Crew 0123, Ship 0123 separated by commas

0471
471
Following report : “# Whoops! We encountered an error trying to process your request.
Our webmaster has been notified and will fix it ASAP!”

I was told our Council does not upload the MBC list into Scoutbook. However AFAIK all of our MBCs are unit only.

Any thoughts?

Is your official 4 digit number 0471? In my council most units use a 3 digit number but all units have a leading 1, 3, 5, 7 or 9.

The format requires the keyword Troop space, 4 digit troop number, space B or G.

Our unit number shows both as 471 and 0471 in different areas of scoutbook. My.scouting seems to show leading zero. Not sure but we don’t wear it on our uniforms. :slight_smile: The MB area shows it with the leading zero. I tried all of the variations but nothing worked.

What I just found worked was to save the MBCs unlisted and marked approved. That saved successfully. Then I went back in and changed to unit listed and entered the Troop 0471 B. That then saved successfully.

Honestly I’m not certain if that is the correct workflow or not but fixed our issues.