Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Can't access Needs Approval report

I’m the cubmaster of my pack. When I go to the Needs Approval Report, it is saying “whoops!..” and gives a blurb about the webmaster being alerted. It’s been going on for a week now. Who can I contact? I was hoping to be able to approve and purchase a LOT of awards soon…

Go to My Dashboard -> Administration -> My Positions and make sure you have the Pack Admin role list ed in your current positions.

Are you a leader in multiple units or just the single pack.

Try to clear your cache as a first step

Ron

I am pack admin in Scoutbook. Been the leader of this pack (only unit I’m a leader for) for a couple years now. This is the first time I’ve had this issue with Scoutbook.

Not a cache issue. I’ve tried in 3 browsers on my laptop, and 2 browsers on my phone. Not an internet issue, as I’ve tried both my laptop and phone on my home wireless and on mobile network.

I am having the same issue, trying to add community service hours. I have tried 3 browsers and my phone!!!

Well, I had my advancements chair try, and she has the same issue. At least I know it’s not just me!

@Angela_Angie_Purpura, service logs have been moved from Scoutbook to IA2 (scoutbook.scouting.org) and require that the person be one of the unit Key 3, or designated in the Organizational Security Manager at my.scouting as a Key 3 Delegate or Advancement Chair.

I occasionally have my admin privileges “revoked” invisibly (i.e. they look fine, but aren’t working). To resolve this, I go to

My Dashboard -> My Units -> Unit Roster -> my name

then reapprove/accept my admin role. It seems to reset something behind the scenes and my admin privileges work again.

ETA: The solution is path dependent, so getting to any Positions directly from My Dashboard doesn’t seem to work.

I tried even going to that link, its not working :frowning: . I am the Scoutmaster, it is just not working today .

All of the Scoutbook servers have been restarted. Can you try again and let us know if the reports are working?

That worked! Thanks @edavignon

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.