Can't Update Leader Account using Edit Profile and receive “Input validation failed”

As Scoutbook Admin/Key Three Delegate, I receive an “Input Validation Error” when trying to save OA Election and/or Ordeal dates for an adult Leader with MID 129631859 accessing through his Scoutbook Leader Account and selecting Edit Profile which shifts me to his IA profile. Details:

The below Scoutbook link was accessed from the Leader side of the Scoutbook Roster. The second line is where ‘Edit Profile” of this account shifts to the IA profile and gives the “Input Validation Error” when entering OA info. This IA profile shows his picture (same one on Scoutbook) and the Leader’s current YPT status and is his primary account.

The below Scoutbook link was accessed through one of his two sons’ Scoutbook accounts (the listed parent was selected). The second line is where ‘Edit Profile” of this account shifts to the IA profile and does allow me to enter OA info. This account does not show his current YPT status - it is just blank and there is no picture in the IA profile.

I contacted my Council Registrar and she stated, “The above leader is showing registered and attached to his scout’s using the MID 129631859. I am not sure why you are having a problem.”

Is this a situation where you can combine the two Scoutbook accounts to resolve the error or something else?

Thanks in advance,

Jay Woolston

@JaphetWoolston I think there might be a bad parent connection.

Try going to the [Scout]'s Connections page in Scoutbook and then:

  1. Click on the parent’s name.
  2. Make sure “Parent / Guardian”, “Adult Leader” and “Merit Badge Counselor” are all checked.
  3. Click “Update” to save.

Those three are checked for both Scouts.

I checked several other adult leaders who have Scouts and see the same differences between the two IA Profiles (i.e the parent profile and the adult leader profile are different, and I expect that is by design)

I think the issue has something to do only with his adult leader IA profile not allowing any changes (prefix, address, OA, etc.).

I can’t change anything on his adult leader profile (Prefix, Address, AO, Swimmer Classification, etc. ). All result in the same “input validation error.”

There must be something in his IA adult leader profile that isn’t validating correctly but not sure what that might be.

Jay Woolston

Remove the adult leader connection, save it, then add it back and save it again.


jacobfetzer I removed the adult leader connection, saved it, and then added it back to both his scouts. No joy.

I believe there is corruption in the data that for this adult leader in Internet Advancement (or the database it pulls information). The “Input validation error” occurs when attempting to change any of the adult leader’s profile data. I’ve tried changing everything that I can and attempt to save but the error pops up preventing any changes.

The “Input validation Error” is too generic to understand what isn’t validating in this adult leader’s record when attempting to modify his Internet Advancement Profile.

Any other ideas?


Jay Woolston

You are able to edit for other leaders in the same unit, I assume?

Have you tried going directly there from instead of from Scoutbook?

Have you tried a hard refresh of internet advancement?

Yes to all. I tried it on another adult leader who is also a parent without a problem. I’m a Scoutbook Admin/Key 3 Delegate.

I tried that second recommendation today after the developers fixed a separate issue that prevented adult leaders who were also parents from showing up in the IA roster. They do now.

I’ve selected shift F5, restarted browser, and used both EDGE and Chrome with the same “Input validation error.”

I think it’s just corrupted data that prevents validation. Just hitting “Save Changes” on his IA profile without changing anything, causes the “input validation error.”

It would be helpful to know what the validation was checking to focus on that data that is causing the error.

I’m working with my Council registrar to see if she can update his name, grayed-out for us, just to see if there is a hidden character or a space in his name.


Jay Woolston

Thanks for your patience as we work through some of the more common causes. I’ve asked the developers to look into this and also make the error messages more useful. I am unsure when we will get a response.

1 Like