Completed Adventure won't update

I am trying to log an elective adventure (game design) for 2 of my scouts who did not complete it yet. It keeps telling me success and does not update. I have tried multiple times now over the past 24 hours. Ive tried on my iPhone Safari and on my iMac Safari.

I logged the same adventure for my scouts who did it a few weeks ago without issue. I also just logged Cyber Chips and that worked.

I’m not sure what’s happening here. I wanted to let Scoutbook know incase there is a but in the system.

Try resetting your Pack Admin role. In Scoutbook:

  1. Go to your Pack Roster page.
  2. Click on your name.
  3. Click on your Pack Admin role.
  4. Make sure the box is checked next to “Position Approved”.
  5. Click Update to save.

Then log out of Scoutbook, and log back it.

Thank you I am also the CC so have full control. I checked anyway incase its all good

Sometimes it can help to reset your Pack Admin role after Recharter. If you have already tried the steps above, but it didn’t help we can try looking at some other things.

What are the BSA member numbers of the 2 Scouts (no names please).

Yeah i hit update on my CC and DL role. But it had let me just add the cyber chip before I sent the message so not sure why Webelo Game Design is having an issue



What are the steps that you are using to try and add the Game Design adventure?

quick entry
enter adventures

its the only way i know how to do it

I think the requirements are not rolling up to mark the overall adventure as completed.

  1. Try going to Scout 1’s main page in Scoutbook.
  2. Scroll down and click on 1’s Advancements.
  3. Click on the rank that Scout 1 is working towards (Webelos or Arrow of Light).
  4. Scroll down to the Elective Adventures section and click on Game Design.
  5. Click on the box next to “Percent Completed”.
  6. Enter the date completed and check the box next to leader approved / recorded.

Repeat the process for Scout 2.

I checked all the boxes in quick entry option they were all there, just as an FYI.

I have to leave now so will try this later and see if it works.


Thank you this worked!

I’m seeing this as a problem. Performing the steps you listed ‘fixes’ it, but I realized I had a Cub with an Adventure sitting on 80% complete even though all necessary requirements were met (and when I go into the requirements page, the ones that weren’t done were grayed out as expected as not required). This was from something marked off in November. I also had a different adventure I marked off today for another Scout, where it grayed out the incomplete requirements that weren’t needed indicating that the Adventure should be done, but it still showed as 67% complete.

I’m seeing this with both quick entry and from the scout’s advancement page now too. We’ll get this reported and push for it to be high priority. I agree it’s a problem.


I don’t know if it is related, it sounds like it is, but I am seeing Completion Percentages not changing even though requirements have been marked as completed. For a Den of Lions I had used Quick Entry to mark off requirements they all did at a Den Meeting but the Adventure failed to show completion. All requirements were marked completed and approved but the Completion was 0%. I went in and re-saved each requirement individually and it finally updated and showed the Adventure was Completed.

Yes, there is something wrong with percent complete.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.