Scoutbook 2.0 - Adventure Completion Issue

I have a new Scout that is on all my rosters and registered. He just completed the Archery and Slingshot adventure and I’m trying to update his profile, but I’m getting a “Rank Not Found” error that is preventing me from updating it.

Has anyone had a similar issue and how did you overcome it?

@AdamDavis3 - is the scout in the proper den? I would also gather that the items were done at a council or district camp event.

Yes and Yes to all of the above.

@AdamDavis3 - what are your exact steps at advancements.scouting.org? Perhaps some screenshots and the scout bsa id.

@AdamDavis3

Check that the Scout is on the 2024 version of the adventures. If they are try toggling the version.

Once I navigate to the Scouts profile, I open their Webelos rank tab and navigate to the Adventures. Then I’m opening Archery and I get 1 of 2 errors depending on which avenue.

If I just mark the overall completed field I get this:

Or if I try to mark individual requirements, I get this.

It also may be that the program is still recognizing Bobcat as a rank and that I can’t award it because he hasn’t completed that adventure.

@AdamDavis3 - bobcat was not required for earning adventures. It was however required for rank.

@AdamDavis3 have you tried quick entry? or tried the good old Shift + Refresh

1 Like

@AdamDavis3 try again please

I’m seeing the same error as well. If I get to the advancement page from the old Scoutbook, some Scouts’ adventures can be entered without issue, but newer Scouts cannot. I get the error below when trying to do a Quick Entry. This is also after a SHIFT+REFRESH.

Yes on both accounts. No difference.

On this rank failed issue - as a temp fix DEVs have said flip the rank versions a few times seems to make it work