Completed Merit Badge Inconsistency

I have one scout that finished the Cooking merit badge. This badge’s completion appears different from all of his others. In the mobile app it does not appear with a completed date. In his Eagle Application report, it appears without our UNIT NO.

Any recommendations? We have not seen this with any other Scout in our unit.

Thanks in advance.


If you provide their bsa member number (no names please), we can check what it looks like in the system.


Thank you!


I just generated an Eagle App for this Scout in Scoutbook and the unit number is filled in on all MBs. Did you generate the Eagle App from Scoutbook or the Scouting App?

Scoutbook, from a computer running Microsoft Edge. I genrated the PDF yesterday and UNIT was blank for Cooking. I just generated it again and it’s populated.

Thank you very much for checking on it. I’ll ask the Scout to check it again from his phone, where this was first noticed.

1 Like

I’ve seen SB leave the unit blank when the MB was earned between the date the scout actually joined the unit and the first membership record in SB (i.e., when the unit was first synced to SB)

Because the BSA systems do not track which unit a Scout was a member of when a MB was earned, if there is not a membership record in SB that cover the MB date, there is no way for SB to determine the unit number to record.

A Scout can edit the unit in the Eagle application after Scoutbook generates it.

1 Like

@graywh You can probably adjust the initial membership in Scoutbook, so that it matches when the Scout actually joined.

1 Like

I appreciate the suggestions. It’s strange because he just completed and was awarded it in 2022, but he crossed over to the Troop in 2017. He’s never been in a different Troop.

Anyway this morning when I run his Eagle report it does show the UNIT NO, and I’m not sure why. It definitely did not show initially, but I emailed our local Director of Field Service who looked at it for us so maybe he was able to update something.


There is nothing a field director can do to fix the problem you saw and there were no updates to the Eagle application in Scoutbook recently.

Were you able to determine how the original application was generated, either via the Scoutbook website, Internet Advancement or the Scouting App?

It appeared this way initially on a smartphone for the Scout’s parent, and then for me via Scoutbook on a computer web browser the same day. But when I ran it again the next day on the same computer and browser, I do see the unit number now. So, it seems like this resolved itself one way or another.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.