Constant timeout errors when editing memberships

I used to occasionally see timeout errors when managing membership or entering information, but for the past week I am getting the errors when I do anything. Transfer scout to the troop, timeout. Add scout to patrol, timeout. It freezes my Scoutbook connection, I have to either wait 3-5 minutes per action for the timeout error, or force quit the program after every action and then log in again. This is happening with both new scouts (just transferred from pack to troop) and existing scouts (synced with council records). It’s truly maddening, the website is basically unusable at this point.

I would install the Feature Assistant Extension since it has the ability to warn about the timeouts and execute a background process to keep you “active” so the auto-logout doesn’t happen.

Afraid I am not familiar with this - is it a browser extension? Because if so, it may help (depending on browser - if it’s compatible) but I generally feel that using an add-on to solve a website-specific problem is less favorable than actually having the codebase for the website corrected to directly address the root cause. Users shouldn’t have to implement a workaround, especially a workaround that requires installing software modifiers locally (what if I’m on mobile? I can’t install extensions on my phone or tablet.)


Are you seeing the 30 minute idle timer or are functions timing out when you try to do something? The extension only helps with the idle timer.

1 Like

The extension works under Firefox and Chrome, and is a lot more than just an early warning system for the timeouts:. Installing the Feature Assistant Extension

However, the BSA mandated a timeout on logins some time back, so that may be what’s catching you up. They have already rejected the idea of removing it, so we’re stuck working with it.

I have had problems with a server site when using a portal, e.g. my.Scouting or Scoutbook, to access the server and the portal site login times-out.

There was a massive internet outage on June 8th, 2021 that caused data server(s) to access to freeze on that day.

Ed - it’s not an idle timer, it’s the endless spinning animation when specific actions are taken. Assigning an existing scout to a patrol, for example, returns the timeout error. Adding a leadership position does not cause a timeout for the same scout. I get the “error - something went wrong, alert the webmaster” page eventually, but the requested action does get registered. I have to close the browser or browser tab and log in again before it responds. As I had a long list of updates to membership and positions, this was really painful. What should have been a 10 minute job took several hours of constant restarting. I tried from desktop, from mobile, from tablet, from multiple locations and multiple internet connections. Same behavior. Really maddening. This was yesterday and today (June 14-15).


We do not have any other reports of this behavior. Have you tried an incognito window to rule out cookies, cache or extensions interfering?

It looks like you have a large number of connections to scouts. You might try going to my dashboard > administration > my account > my connections, and click clean old connections. I’m not certain if that will help, but it should reduce your connections.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.