Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Scout can't log into Scoutbook

My husband and I can both log in, but neither of my Scouts can. They have tried multiple devices all with the same result. It’s been this way since at least 9:30 this morning.
Screen Shot 2022-01-08 at 1.18.48 PM

1 Like

Forcing a refresh in the process seems to get you past it

To force a reset of the webpage:
Enter the address of the page you want to force refresh in the address bar at the top of your web browser. Press and hold Ctrl on Windows or ⇧ Shift on Mac. Holding “Ctrl” or “Shift” can unlock added functionality on your computer keys or desktop icons. Click the refresh button ⟳

I tried it. Unfortunately it didn’t do the trick. The problem is it isn’t just one browser. It’s every browser on multiple devices just for my kids accounts.

1 Like

Would you give us their member IDs?

Note that SUAC only needs the BSA ID (as @WilliamNelson asked), not their names. If they need more personal information, they’ll send you a private message.

130797919 & 137087979

Thanks when exactly do they get this error?

The system says they logged in 20 hours ago; and the 2nd Scout an hour ago. Have them try again, go to http://scoutbook.scouting.org and then do a hard refresh before logging in.

You have to click refresh before it gets to the error page

I tried logging in before I posted their IDs but still got the error. I haven’t been able to get either of them logged in yesterday or today. They have tried their phones, my phone, my laptop, and my husbands laptop. We’ve tried Chrome, Safari, whatever browser windows is using right now.

So login and while it’s spinning click refresh?

@AudreyReed yes that works consistently for me

When I tried to force refresh while it was spinning to log her in, it dumped me back to a login page. Tried to log in again, got the error again. I did a screen capture I can send to you, if you’d like.

Interesting behavior - It’s obviously logging them in because after I get the error, if I go to my.scouting.org, they are logged in there. It’s just not loading scoutbook for them.

@AudreyReed - I just tried with my son’s account and have found that I can get into scoutbook via my.scouting.org > Internet Advancement in the BSA links > then once that loads click on scoutbook on the left hand side.

I do get the whoops and refresh in Edge has not gone past that error.

My son’s bsa id is 126955188

2 Likes

I just got the error logged into MY account putting in merit badge requirements for scouts.

That’s how I have been getting my son in.

I confirmed I can get there on my laptop this way, but when I tried on my phone (that’s how my Scouts log in), it errored out when it made me log into IA after clicking the IA link from my.scouting.org. And that’s not how it should have to be.

You can use the scouting app for mobile devices instead.

The Scoutbook app gives the same error. The Scouting app doesn’t allow the same ability to make notes for advancements and merit badges that Scoutbook does. It only allows to check the box and mark a date.

1 Like