Detailed Assessment- Can't Score or Add Comments

Hello all! One of our UCs created a Detailed Assessment and is unable to score or add comments to it. Just tested it on one of my units and have the same result. Anyone else? (BTW, the first one was created as a future/scheduled date- I tried it the same, plus changed it to today and can’t do anything.)

Just tested locally on my Council - and I was able to create a Detailed Assessment with no issues.

This time of year, always make sure your registration has processed, that you are using Chrome or Edge browsers, and that your cache has been cleared, or you are using a private browsing window.

Just did some more research and it appears to happen when I schedule a Detailed Assessment. If I create one on the spot, it’s fine. But, if I schedule it, it won’t allow me to edit anything. (Using Chrome, unit has had its recharter posted and I’m active through 1/31/24.)

Correct, you enter your info on the date planned.

1 Like

Thanks! For some reason, I thought I remember being able to add notes prior to the scheduled date. Thank you for clarifying.

You should receive a link in your email for adding comments.

Sorry to piggy-back on your post, but was wondering if there is a consensus as to when scoring is done.
Do you only use it when doing a Detailed Assessment, or at any time?

You have to assign a score when leaving a simple or detailed assessment.

That helps
That helps
That helps
They made me use 20 characters

1 Like


The easiest way to get the minimum character count is to include the name(s) of whomever you are responding to. Gets me out of that jam all the time. :^)

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.