Link from scheduled detailed assessment redirects to error page

I scheduled a detailed assessment with one of the units assigned to myself. The link to assessment form redirects to the 403 error page. The scoutmaster of the unit and myself both are unable to use the link; however I can access the detailed assessment in Commissioner Tools directly without any errors.

I have tried clearing my browser’s cache (Firefox) with no change in error.

Brian -

Firefox is not one of the “preferred” browsers - however, try using a “Private browsing mode” window (which does not store or use cache) and see if that improves things for you.


I attempted to open the link in a private browser with the same redirect to a 304 error page. I also tried using Microsoft Edge with the same result. I do not have Chrome installed on this computer.

I know the system works as I have scheduled a detailed assessment with a different unit and had no issues.

Brian -

My educated guess is that we have a bad URL. 403 errors can come in several flavors, but that seems to be the most frequent cause.

We are seeing the same thing for detailed assessments being sent out to all our units. Something with the system is broken.

I am experiencing the same problem. URL embedded in the assessment invitation email goes to 403 error. Neither the unit Key 3 nor I can open it.

I have reported this already, but the three day weekend has slowed things down a bit.

Thanks! How will we know when it is ready for use again? Should I just check back here?

I will post when I know it is fixed.

The fix went to QA late yesterday, and should be tested today (11/14).

Thanks for the update. Hoping it works!

I had a Key 3 leader cite the same issue on 11/15/23. I asked him to try it again last night to see if it had kicked in, but haven’t heard back yet.

Any word from anyone else that this is fixed?

I have not tried it yet - waiting for Ron to confirm the fix works. He said he would post when he knows it is fixed.

1 Like

Sorry to bother you. Do you know if this is fixed yet? I need to initiate a detailed assessment. If it’s still not fixed I’ll have to do it the old-fashioned way, with paper forms! lol


I did not get an update yesterday, so I would use the old fashioned way.

Good afternoon. I was informed that an update was pushed earlier today. Please let me know if the problem still exists.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Just wanted to reopen this, because it is still not working.

@RobertBrodner did you clear the cache in your browser?