Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Did not get charter papers for signature

Hi all, I rechartered 3 units: Pack, B Troop, and G Troop. I only got two emails with subject line “Please sign [Unit] Charter.” I did not get the one for the B Troop. I already contacted the Council but I did not get a reply. Is there any way for that email to be sent so that I can go ahead and sign it? I’ve signed the charters for the Pack and G Troop already. I’m the COR and Unit Executive for all three. Thanks.

My understanding is there is supposed to be a way to re-trigger the e-mail to send. From the FAQ:
Q – The email to my COR was never sent and now my recharter is locked. How do I resend the email?
A – If your email was not sent, you can return the recharter page and a button will become visible. This
button will regenerate the email without reopening the recharter.

If the system thinks the email was sent but remains unassigned, you have to wait 4 days to resend it. See if the button appears in a few days. It’s apparently pretty obvious when you go into recharter.

This is a known issue with no fix currently.

UNLESS the button reappears for you . . . but I have not yet heard from anyone who has seen that button . . . . but, they are also probably not posting here because it’s working for them and they do not have a problem! ;^)

Here is another thread on the exact same subject you could review if you’d like to commiserate with the rest of us. ;^)

Haha. Commiserating here. I will wait and see. I’ve checked the spam folder just in case. But it’s not there. So, I’m hoping the resend will show up over the weekend as I just want to go to the Council to pay in one go for all units.

Thank you all for your replies. I will update here when the button appears.

Happy weekend!

Prudent, but it would be understandable if one of the key 3 didn’t get it, but all? Pretty unlikely.

@MHTroop511KDC - in looking at the "Please sign X Unit Charter emails I received it shows who was sent the email on each unit.

You are one of a group of signers who can sign this document. Only one of you needs to sign. The group includes… with the list of emails

@JeffPershing , @brantgurga

1 Like

None of the other signers got the email. But I logged in today and got this screen.

I clicked “Generate Charter” and got his.

I got the email after!

2 Likes

@MHTroop511KDC - I gather you are on the trail to closing books on this recharter? I submitted each of my units one at a time from least change to more modified and all went through prior to 8 Dec. Now I wait on council…

1 Like

The Unit where I didn’t receive the charter papers for signature right away ended up with an error. Administrative fees were added even though I selected “Pay at Council.” Our council caught the error when I went to the office for payment. Good thing I brought extra checks with me. So, if this happens to you, pay attention to the fees after you get the paperwork sorted out.

Thanks.

1 Like

I am having the same problem with my submittal. My registar went into some system and changed my primary email, removing the previous email, which is my work email address. I have checked spam/junk/ every fold possible for where the heck the email is with the documents for me to sign (I am the COR and the one completing all the rechartering so it comes directly to me to sign)… I was able to get the button to generate charter, but it is no where to be found. Not for anything, but I have been doing the rechartering for my troop and pack for 10 years now and have never had any problems with the old system. I still have my Pack charter to submit, but I don’t want to submit it if it too is going to end up in electronic heaven which seems to be where my Troop recharter is. Please help.

@StephenEverson if I had to guess your old email is in recharterr - MAYBE clicking refresh roster could bring it is but we have seen that fail also - probably best for council to do a whole reset on the charter

Thank you for the response. I am working with my registar to see if we can correct the problem. I have suggested letting me bring my computer over to council office and connect (if they have wi-fi) and for me to go through the steps with them seeing what is on my screen as I go through the process. I am holding off on submitting my pack charter until the troop charter goes through. I have been in my main inbox and spam box to see where this email may have gone to… but it is not there… :frowning:

How’s your recharter? My 3 units are in limbo. The council may be behind on paperwork.

This is the worse year for rechartering that I have ever been through. After the suggestion of having my registar reset my charter, I took my computer into Council office and sat down with the registar so she could see what I was seeing on my side of the process. I had to start from scratch and enter everything again. I was able to process my charter and everything went right through. I think by her fixing the email address for me in the system (although I had updated my email on my profile prior to submitting my troop roster), I got my signature email, signed it and completed my charter. Now, she has not posted my recharter so I still have my old roster on my Scoutbook. The next task is to submit the Pack roster. This has been an ordeal in getting folks to pay. We are trying to the payment record on Scoutbook to have folks know how much they owe. First time for this. Plus dealing with how folks registered online made payment for 2022 fees if they registered after 10/1… We still need to collect dues from the parents so they help pay for the operation of the Pack - like Pinewood derby cars, trophies, badges, etc. That is not collected when they pay online. So you have to explain to parents their online payment was just for registration, not pack dues.

1 Like

Totally agree that old recharter was better. BSA IT likes to fix things that aren’t broken and never fix things that are.

@scouter11 - well the old recharter system was on scoutnet and as such had to be migrated to the new stack. Personally I had no issues with the new method. I took my time and worked step by step and submitted all three units successfully.

1 Like

For our troop, the old system took 2-3 months before being posted. This year: 7 days.

For my 3 units (G troop, B troop & F Pack) three different individuals did the work. One was going to pay by e-check but the system did NOT recognize the paying institution (credit union) so paid by credit card. Other two pay at council. By the 5th 2 of the units indicated in Internet Recharter as Done the other unit was on hold. Since I had to go to council office on the 6th for a completed eagle, I talked to our Field director about that and other things for the newly Combined/reorganized District. The FD stated that all 3 were in the done status. I did not check on the evening of the 6th or until a few minutes ago. Internet Recharter is NOT available and the Internet Advancement Rosters are correct for Recharter (Have not looked at my.scouting or SB)
So a 6 - 9 day (probably 7 since 8 & 9 are the weekend) processing time is fantastic.
It worked ok - my major complaint is the inability to print a draft report before finalizing (which I was reported in the Dec 28,2021 IR change log).

1 Like