Unable to generate your charter for signature

I am trying to process our pack’s recharter. When I try to process the payment step (I have selected pay at council), it times out and I get this error:

“Whoops! It looks like we were unable to generate your charter for signature. No payment has been taken. Please retry again.”

After browsing the forums, I tried to submit with an incognito window, but the same error happens. Any ideas? My BSA member ID is 135398019, and my unit is Pack 3933.

Thank you!

Update on this - after the fourth time trying to submit, I received the charter document in my email to e-sign, so I did that, and I received the confirmation with the final agreement. However, if I log into Internet Recharter, it still indicates that we need to submit. So, I honestly have no idea where I am at with this process. Any help appreciated.

@RhiannonShoults - are you stating that you received an email stating that you’re done signing %unitxxxx% charter with the button to open the agreement ?

@Stephen_Hornak Yes, I received an email saying I am done signing Pack 3933 Family Charter, and I can open the agreement.

Does that mean I am actually done? Every time I submitted on the payment screen I received the “unable to generate your charter” error, so if I log into Internet Recharter it still shows me on Step 1 (Complete Recharter Information) and it looks like I still need to validate recharter and pay/move on to Step 2.

@RhiannonShoults - if you scroll to the end of the agreement is the status page. What does the page list.

You would also have a submission complete email

@Stephen_Hornak The status is Signed, and it has a Transaction ID. The last entry in the document history is Agreement completed.

I have not received a submission complete email.

@RhiannonShoults - there is a submit button at the end of the Adobe sign doc

@Stephen_Hornak I am sorry, where is it? If I open the signed PDF, I don’t see any kind of submit button. If I open the first email I received (“Boy Scouts of America has sent you charter to sign”) and click that link, it just says the document has already been signed.

@RhiannonShoults - I look at the signed doc and at the end is the Final Audit report with the charter history listing. I also did a pay by card and submitted that way so I suspect since you chose pay at council that you are doing this the old school way. Heading to council with the agreement and check.

@Stephen_Hornak Yes, the rest of my paperwork is already in with the council, and our treasurer will be taking a check by this week.

I went ahead and did the “validate and pay” step again, and this time it went through and I received my Submission Complete email, and when I log in to Internet Recharter it shows my recharter as locked. This generated a second charter document for me to e-sign, which I went ahead and did. Hopefully nothing gets confused with there being two signed charter documents! Thanks for the help.

@RhiannonShoults - excellent glad it worked. Having done unit recharter for a decade now it is all about the process flow