Entering Advancement issues

I am attempting to put advancements into scout book. When I enter the advancements they are accepted however when I attempt to award a rank advancement it says. “The scout still needs to earn.”
It doesn’t tell me what they still need. It isn’t just 1 scout, it is every one I have attempted to enter info for. When I click into an individual scout with this issue, I can see all the adventures listed, however when I print the advancement history report, they are not listed on there. They are also showing up in report for me to take to council to purchase everything. Is there a step I am missing? Or is this a glitch?

@JohnMcConnell - are you doing this in advancements.scouting.org ? If so, could you go to scoutbook.ascouting.org and to that scout and their advancement to see what is missing… most likely it is cyber chip or protect yourself.

I will try that. However, it worked fine for one scout within the den and the rest are an issue. I tried another den and I am having the same problem. I have compared them everything looks fine. Ironically the one that it did work has one less adventure than the others. I stopped after I realized same issue was happening with all scouts.

Are the scouts on most current rank version?


See the attached pictures

Yes. See the pictures below of the issue that I am having.

you should log into scoutbook.scouting.org

Donovan and do what?

look there it is clearer - I bet it is parent pamphlet or Protect yourself - you can also force complete in SB by clicking the box by the % Complete bar

I have compared them. There is nothing different, and please tell me why is there adventures that I put in not showing up on their history when I print it out…see above pictures.

Here is a screenshot of that den. You will see they are all at 100%, however only one I was able to advance to Webelos

And again, I think the bigger issue is, it doesn’t seem like they are actually getting fully submitted for some weird reason since they are not showing up in the cub scout history print out for the ones I cannot advance.

What do you mean advance to Webelos? be given the Webelos rank? They are in a Bear Den? If this is a Webelos Den go to Edit Den and Advance the Den to Webelos there. Then you can award Webelos Rank

Thank you! Finally figured it out! Hopefully it works now. Fingers crossed.

Working. Something so simple, I should have realized it. Thank you for your assistance!

@JohnMcConnell - you may want to bookmark this for future reference and for others that will succeed you.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.