Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Error trying to log Eagle project service hours

I’ve tried several times over several days to report an Eagle project on the reporting website. I’ve been doing this for years, but I can’t seem to enter this latest one. I fill in all of the information, and when I click Submit, I get an error.

There was an error recording this information.
Please review your answers and try again.

No indication at all of what the error is. Attached is a screenshot.

How can I get past this? Thanks for any help
YiS,

Have you tried a private browsing window, a different browser, or different device?

I normally use Chrome, but I believe that I tried Firefox and IE. I’ve had problems entering data in this website before, where I would enter everthing in, click Submit, and I was taken to the Home page instead of getting the certificate. Entering the data in again though, eventually got me the certificate. I’ve never had this problem before though, and I’ve been entering service hours at this website for several years.

I even had another ASM try to enter the data, and he got the same result.

Perhaps I need to create a new account for this, but why?

I’ve occasionally had your previous issues too. You could try clearing cache, also. And I’d try entering it without Scoutbook or any other bsa sites open.

If that fails, send an email to MyScouting@scouting.org.

Cleared cache, no SB login (or any scouting.org “SSO” - quotes because this SSO isn’t really single)
I’ll send an email.
Thanks