Error entering hours for Eagle scout service project

Trying to enter hours for an Eagle Scout project that occurred over 4 days. The scout only gave me the total hours. Did not break down the hours for each day. Received the error message:
Error Whoops! Looks like we encountered an issue temporarily. Try again later.
Tried this twice on Sunday and again today. Getting the same error. Because this was more than one day, there are scouts with 15 hours, but they have already been entered. First screen shot is the error. Second and third screen shot is data for the scouts I’m trying to enter

It wouldn’t surprise me if the 15 hours is causing a problem. You could try artificially splitting the event into 2 days. The actual days worked do not matter in the system, only the total number of hours.

Split it into two days but the hours were not the problem. I get the error message as soon as I attempt to enter hours for the non-registered youth. I have one that worked 10 hours. I have all the other hours entered without any errors

@TwilaLytle - i was able to enter a test service item with just a single non-registered participant with 10 hours and it saved. I had not done it with other scouts included.

I am getting this same error and I’m entering 4 hours. This has been going on for about 3 weeks for me. I am unable log service hours at all.

I got the same error showing in your 3rd pic, but yet, somehow, all the changes I made were saved. I found it odd, but I got my data entered as intended.

My data is not entered. I am in charge of logging service hours and I am not able to. I keep trying, and keep getting the same Error message. I don’t know what more I can do. Who do I get in touch with about this? I do not see it changing on its own.

Which browser are you all using?

I’m using Chrome on a Win 10 PC.

Not sure I responded to this. I was able to get all service hours entered by having one event for all scouts and another for non-scouts. Did not seem to matter that I entered 15 hours for some scouts. As soon as I attempted to enter the non-scout with the scouts I got the error. message and had to cancel out.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.