Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
âś•
BOY SCOUTS OF AMERICA

Scouting Forums

Service Log error entering service hours for Eagle project

We have a Scout getting an invalid category ID error when entering hours for Eagle project. He is selecting Eagle Scout Service Project from the drop down. TIA

@DavidBacon - is the scout entering the hours on the scouting app ? I just tested that with my son’s account and I got the same message. I do know that eagle service project hours are reported 9n servicehours.scouting.org as the record.

1 Like

Eagle Scout service project hours from the workbook are still entered at servicehours.scouting.org.

Please check with your district / council. In many cases, there is an Eagle processor at the district or council level who enters the project’s service hours.

Hi Jennifer. This is a Scout entering hours worked for another Scout’s project. Eagle project was selected from the drop down of available options. I did not see another option that applied. I understand the Eagle candidate would enter hours for his/her project, but how are those Scouts supporting them supposed to document their hours?

Is he using the “Assisted someone else’s Eagle Project” category?

There is no such option in the drop down

@DavidBacon - that seems to match what I observed in the scouting app. Have the scout try using scoutbook.scouting.org to enter the service hours.

Hi Stephen. Need to make it easy on the Scouts. If all other hours can be entered in the app, these should to. No need to go somewhere else to create confusion, especially when there is an option for Eagle project in the drop down. This should really be cleaned up.

@DavidBacon I have reported the error message.

1 Like

@DavidBacon - my thinking was to make sure the error is isolated to just the app.

Understood. Will work on that and report back.

Stephen, I used my son as guinea pig so I can see what is being done. When he went to the site you suggested it asked him to create an account including asking for unit ID (which it says to get from council) and all of his personal info. I had him cancel out.

This is well beyond what a Scout should have to do to enter hours in his log. This used to be a very simple process that took seconds. Hopefully Jennifer’s request can resolve this.

@DavidBacon - well thanks. I did log into scoutbook.scouting.org with my son’s credentiials… The same login for the scouting app by the way… The service hours choice there is assisted with eagle service project. So it Ppears to be a naming issue in the app.

Thanks Stephen for helping to troubleshoot. Maybe if the selection from the drop down within the app is updated this will be resolved.

Was this ever resolved? I’m trying to do the same. I got a message that the hours had been recorded, but upon looking them up, they didn’t appear to exist…Not sure why?

I repeated the process assuming I’d messed something up…same result: message that says it went through, but is not accessible.