Error when adding a connection to a scout that is an existing Scoutbook user

I have a parent that is already tied to one of their cub scouts, but noticed they were not a connection on their other cub scout. I was successful in searching for her in the system at the top of the add connection form. After selecting her name from the search results, it collapses the section in the middle for creating a new person/ID, but when I tried to submit the form after typing in a message, it keeps saying that it can’t submit because it is missing the information that would be entered for a new person/ID. It also kept searching when I was hitting enter while typing in the message field. I tried both in Chrome and Edge browsers. Any help would be greatly appreciated.

@GeraldLanglois admin can use Unit Roster > Connection manager > add connection there in the matrix - then go to connection and click the parent checkbox

Thanks for the suggestion. I have full admin for the unit and that method only lets me add them with the ability to select the view advancement and to view the profile, not full permissions after labeling them a parent like you can via the add connections method. The other permission options are grayed out.


Jocko Langlois

yes - then go to the scouts connections > find the parent and click the parent checkbox

Got it. Thanks for the workaround solution! I do hope the other method will get fixed to work as intended to make it easier though. If she wasn’t already tied to an active cub scout in the pack, but already had an account, I don’t think this workaround would do it or you would potentially have to do weird stuff like adding them as a leader role first.

log into Scoutbook with their ID and PW, navigate to My Account → My Connections then click the “Connect to Scout as Parent/Guardian” near the top of the page. The parent will need the Scout’s BSA Member ID, last name and date of birth to connect.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.