Error when Removing Member from from roster in Internet Recharter

I receive the following error when I try to remove someone from my roster. I have attempted to remove both adults and youth and get the same error.

"org.mule.weave.v2.exception.UnexpectedFunctionCallTypesException: You called the function ‘contains’ with these arguments: 1: Null (null) 2: String (“Council Registration Acceptance”) But it expects one of these combinations: (Array, Any) (String, String) (String, Regex) 8| if (roles contains “Council Registration Acceptance”) ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ Trace: at contains (line: 8, column: 5) at main (line: 8, column: 11) " evaluating expression: "%dw 2.0 output application/java import containsAny from modules::Common var roles = vars.auth.roles flatMap ($.roleTypes) var unitRoles = [“Unit Registration Acceptance”, “Unit Youth Registration Acceptance”, “Unit Adult Registration Acceptance”] — if (roles contains “Council Registration Acceptance”) ‘COUNCIL’ else if (containsAny(roles, unitRoles)) ‘UNIT’ else ‘’ ".

This was reported last week - no info yet on a fix

Having the same issues. Following for a fix

Troop 658 in council 576 getting same error while removing several users, either as a group or singly. They are also getting it when trying to add a user.

Following for resolution.

Will ask registrar to open ticket.

1 Like

Troop 1331 in council 576 also getting same error.

That’s two today…

Having a similar error code “Batch cannot be updated”


Receiving the “Error. This batch cannot be updated” response when I try to remove a member. Any resolution to this? How to refresh the batch?

1 Like

I am having the same problem with the “Batch cannot be updated” after our recharter was reset this morning to correct an issue with the fees for new Scouts and leaders.


Having the same issues. Following for a fix.

I think this thread got mixed. “Batch cannot be updated” is a different error from the originally listed UnexpectedFunctionCallTypesException. I just received reports from 2 units experiencing the Batch cannot be updated one and I sent a message to my council’s registrar about it. Haven’t seen that one acknowledged here.

“Batch cannot be updated”, Troop 113, Denver Area Council. Following for the fix!

“Batch cannot be updated”, Pack 397, Crossroads of America Council. Following.

Same here, “Batch cannot be updated”. I was worried that since I had worked on it some previously, it had submitted the data. Hoping it’s just a temporary maintenance item.

For those of you getting the “batch cannot be updated error”, we need to know the bsa member number of the person trying to complete the recharter, the unit, and the action taken, and the bsa member number of the individual you are trying to update when you get the error.

@jacobfetzer - Thank you for your help! I am working on the recharter for Pack 20 and am BSA member ID #12945969. We previously had issues with new Scout and leader fees showing up as $0.00. Our council reset the charter this morning, which seemed to resolve that issue.

Tonight I went to redo the edits, but now get the same “Batch cannot be updated error” for every change I try to make. As a few examples:

  • Cannot remove adult member #133523061
  • Cannot remove youth member #135728969
  • Cannot update position of member #13483516

I’ve reported this to the developers.


Thank you, I am working on recharter for Pack 148, my member number is 13572255. Yesterday I was unable to edit an adult member who took over a den, but I was able to remove youths and adults who are no longer with the pack. Tonight, I am unable to edit and I cannot take action on members at all without getting the ‘batch cannot be updated’ error.

Examples include:

  • Cannot remove adult member 136580602
  • Cannot remove youth member 13866300
  • Cannot update position of member 136713672
  • Cannot mark member 136713672 as a multiple

Our Troop recharter is getting both Batch cannot be updated and also JWT Token Missing, when trying to delete a leader or scout. /what is that and how do we fix it? Help.

1 Like

@RichardCram I’ve reported yours as well.

I am working on Pack 3841 recharter and I am getting the same Batch cannot be updated. My BSA # is 13321821. I was trying to update BSA # 135266601 to committee member and I cannot update any adult information.