Error when trying to add a connection

I am trying to add a 2nd parent to a scout and am getting this error:

Whoops! We encountered an error trying to process your request.

Our webmaster has been notified and will fix it ASAP!

I waited 48 hours and have tried again, but am still receiving this same error.

I think parent search is still broken. Try providing the parent with their scout’s BSA ID, and having the parent “Connect as Parent” from their My Connections page in their own Scoutbook account.

The best solution if the parent is not associated with the unit is to your Unit’s Roster page then select Connection Manager, select the cell between the parent and Scout, select an option to create an initial connection then go to the Scout’s connection page, select the parent and turn on the Parent/Guardian switch.

If the parent is not already associated with the unit, the parent can connect themself by logging in to Scoutbook, going to their Connection page and selecting Connect to Scout as Parent/Guardian.

If the parent does not have a Scoutbook account, they can create a ID then use that to log in to Scoutbook. An account will be created.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.