Existing Troop parent trying to complete application for Cub Scout

Mom had started the cub scout application using the link provided by the pack. She entered her son’s name and birthdate but when she completes her information, her birthdate is greyed out. Now when she selects the link, she gets an error - “you must be over 18 to complete application” right off the bat. She’s using Chrome on an iPhone.
She has an existing boy scout in our town as well and she’s hoping to see both boys when logging into Scoutbook. We are CT Rivers Council. BSA Troop 58 and BSA Pack 58. Her scouts SB# 13304982. Her initials are VB. She is unable to enroll her son in the Pack.
Thank you!

so is this through beascout?

We tried using the link provided by the pack and we tried going to beascout and clicking on cub scouts, then entering zip code to find the pack. Both ways she received the message that she had to be 18 to complete the application.

I looked at wrong account - she does not have a DOB in system - council can fix it in AKELA