Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Hiking logs

I need help entering a hike that is 4.5 miles, it keeps saying to enter in a whole number. Is this something new? We have a hiking club so we don’t want to round up or down, we want to be accurate as we give out hiking milestones.

This has already been submitted as an enhancement request.

I don’t think this is an enhancement, it is a bug fix. The update on 12/28/2020 included fractional hours and miles. Somewhere along the way, there was a bug that caused reversion.

1 Like

Yes, it is a bug. The developers are aware.

1 Like

Thank you Jacob. However I’m also not able to log hiking events even WITH a whole number (my pack’s hiking event from this past Saturday was 2 miles). I tried it in both Firefox and Chrome - same very basic ‘error processing request’ message popped up. I tried looking in the web developer tools but it’s a bit hard to understand what’s happening – other than that IA is returning an http/500 error.

@PaulLanzi, I just (as in right now) successfully logged a hike that we did last week. I created the event, added the youth and adults, and set the elevation and distance. I set the distance as a whole number (less than 1/10-mile error relative to how far my GPS thinks we traveled). Everything went exactly as expected, no errors.

I’m not sure what the difference is between my experience and yours. What’s your role in the unit? Is that role accurately reflected in my.scouting?

Interesting. Yeah, my.scouting shows me as Committee Chair (which is correct). I deleted the event and re-created it – same problem. I can create the event (with no participants) but when I go back in and edit the event to add participants and the mileage, that’s when I get the error. Doesn’t seem to be any combination of entries into the Participants list nor to the mileage field that gets me past the error.

What if you create the event and add the participants all in one operation? That was how I logged the hike event I created. I wonder if it’s the “editing” step that is causing some sort of permissions error.

Not that it should be causing issues, mind, just that determination might help with diagnosis of this particular error.

ok - interesting! That worked - thanks Charley.

So the workaround is:

  1. On the create event screen, add participants first
  2. fill in the rest of the event details
  3. once the event is created, you can go back and successfully add additional scouts
1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.